Closed Bug 432033 Opened 12 years ago Closed 12 years ago

Accessibility fixes in mail/components/preferences XUL files

Categories

(Thunderbird :: Preferences, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3

People

(Reporter: MarcoZ, Assigned: MarcoZ)

References

Details

(Keywords: access)

Attachments

(1 file, 1 obsolete file)

Add missing label/control relations, aria-labelledby (for those expressions made up of several controls), and other accessibility-related markup that may be missing.
Attached patch Patch (obsolete) — Splinter Review
Attachment #319192 - Flags: review?(philringnalda)
Attached patch Updated patchSplinter Review
Got rid of xul:description/aria-labelledby constructs and replaced with xul:label markup. Affected files: display.xul, receipts.xul, sendoptions.xul, viewPasswords.xul. In sendOptions.xul, also added the control attribute to the xul:description element that says "Note: ...". That was, the combobox gets this added information in its accessibleDescription so users can ask for it.
Attachment #319192 - Attachment is obsolete: true
Attachment #320668 - Flags: review?(philringnalda)
Attachment #319192 - Flags: review?(philringnalda)
Blocks: 370391
Comment on attachment 320668 [details] [diff] [review]
Updated patch

After all the time I took to review it, you'd think I'd have more than just a handful of nits, wouldn't you? Though most of that time was talking myself out of other nits that aren't your fault or your responsibility to fix (or, often enough, even in lines you were touching). r=philringnalda, with:

>Index: mail/components/preferences/advanced.xul
>+            <label value="&markAsReadEnd.label;" id="markAsReadEnd"/>

id as the first attribute, please: we're not quite perfect about doing that, but "more often than not" counts as intended style, given the inconsistency in our prefs xul.

>+              <label id="connectionTimeoutLabel" value="&connectionTimeout.label;" accesskey="&connectionTimeout.accesskey;" control="connectionTimeoutBox" />

>+              <label id="connectionSeconds" value="&connectionSeconds.label;" />

Please remove the space before the "/>" - this isn't pretend-XHTML served as HTML, which is the only place that comes close to making sense.

>Index: mail/components/preferences/display.xul
>+            <hbox class="indent" align="center" role="group" id="displayText">

id first here, too.

And thanks for being patient.
Attachment #320668 - Flags: review?(philringnalda) → review+
Checking in mail/components/preferences/advanced.xul;
/cvsroot/mozilla/mail/components/preferences/advanced.xul,v  <--  advanced.xul
new revision: 1.26; previous revision: 1.25
done
Checking in mail/components/preferences/changeaction.xul;
/cvsroot/mozilla/mail/components/preferences/changeaction.xul,v  <--  changeaction.xul
new revision: 1.8; previous revision: 1.7
done
Checking in mail/components/preferences/compose.xul;
/cvsroot/mozilla/mail/components/preferences/compose.xul,v  <--  compose.xul
new revision: 1.16; previous revision: 1.15
done
Checking in mail/components/preferences/display.xul;
/cvsroot/mozilla/mail/components/preferences/display.xul,v  <--  display.xul
new revision: 1.8; previous revision: 1.7
done
Checking in mail/components/preferences/dsn.xul;
/cvsroot/mozilla/mail/components/preferences/dsn.xul,v  <--  dsn.xul
new revision: 1.2; previous revision: 1.1
done
Checking in mail/components/preferences/general.xul;
/cvsroot/mozilla/mail/components/preferences/general.xul,v  <--  general.xul
new revision: 1.15; previous revision: 1.14
done
Checking in mail/components/preferences/offline.xul;
/cvsroot/mozilla/mail/components/preferences/offline.xul,v  <--  offline.xul
new revision: 1.6; previous revision: 1.5
done
Checking in mail/components/preferences/privacy.xul;
/cvsroot/mozilla/mail/components/preferences/privacy.xul,v  <--  privacy.xul
new revision: 1.17; previous revision: 1.16
done
Checking in mail/components/preferences/receipts.xul;
/cvsroot/mozilla/mail/components/preferences/receipts.xul,v  <--  receipts.xul
new revision: 1.4; previous revision: 1.3
done
Checking in mail/components/preferences/sendoptions.xul;
/cvsroot/mozilla/mail/components/preferences/sendoptions.xul,v  <--  sendoptions.xul
new revision: 1.6; previous revision: 1.5
done
Checking in mail/components/preferences/viewpasswords.xul;
/cvsroot/mozilla/mail/components/preferences/viewpasswords.xul,v  <--  viewpasswords.xul
new revision: 1.3; previous revision: 1.2
done

Checked in with review comments addressed.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.