Last Comment Bug 432097 - Live bookmarks need 15 minutes to reload if connection drops before the first update
: Live bookmarks need 15 minutes to reload if connection drops before the first...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: 3.0 Branch
: x86 Windows XP
: -- minor (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 440563 (view as bug list)
Depends on: livemarksIO
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-04 02:08 PDT by Andrea
Modified: 2012-02-25 02:41 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Andrea 2008-05-04 02:08:30 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050206 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050206 Minefield/3.0pre

I get this error message in all the RSS feeds I've subscribed when I start Firefox with no internet connection (which is obvious).
The strange thing is that the feeds aren't reloaded even after I get an internet connection and restart firefox too quickly, so it seems like on the second start (when an internet connection IS available) firefox doesn't try to reload the rss feeds, so I have to manually reload them one by one.


Reproducible: Always

Steps to Reproduce:
1.Open firefox with no internet connection available: no live bookmark is loaded, error message is displayed instead
2.Connect to the internet
3.Close firefox and re-open it quickly (not too quickly, else you get the "another instance is already running" dialog)
4.Even if an internet connection is now available, Firefox doesn't try to reload the feeds at startup, you have to do it manually, or wait some seconds more before restarting it
Actual Results:  
Live feeds don't reload even when connected to the internet and firefox has been restarted (quickly)

Expected Results:  
Firefox should always try to reload live feeds on startup, even if another instance has been closed only a few seconds before.

Firefox 3 default theme for win xp in use.
installed Extensions:
Adblock Filterset.G Updater 0.3.1.3 (forced with extensions.checkCompatibility set to false)
Adblock Plus 0.7.5.4
Italian dictionary 3.1
DownThemAll! 1.0.1
IE Tab 1.5.20080310
NoScript 1.6.4
TabMixPlus 0.3.6.1.080416
UnPlug 1.6.06
Comment 1 Carsten Book [:Tomcat] 2008-05-19 14:49:59 PDT
Does this happen on specific live bookmarks/rss Feeds ? Can you provide a url to this feeds ? 
Comment 2 Andrea 2008-05-20 01:24:39 PDT
It happens with all of my live bookmarks.
Here a list of some of them:

http://www.hwupgrade.it/rss_news.xml
http://www.swzone.it/swzrss_news.xml
http://www.freeware-guide.com/html/updates.xml
http://www.autoblog.it/rss2.xml

Now using 20080519 nightly, still having this issue.
Comment 3 Marco Bonardo [::mak] 2008-05-20 02:39:20 PDT
have you tried waiting for ten minutes? Do they update after that time?
On feed failing we set up a timeout expiration to avoid retry loading them immediately, that timeout is 10 minutes actually.
Comment 4 Marco Bonardo [::mak] 2008-05-20 02:40:45 PDT
notice: the timeout could be 15 minutes really since the first refresh after timeout happens at that time. So try waiting and see if they are updating after that time.
Comment 5 Andrea 2008-05-20 04:02:35 PDT
Very strange, no refresh even after >16 mins.
I think that, even if it worked after 15mins, this interval is way too long.
Let's suppose a user has many feeds (I have 23 subscriptions) and network connection falls, if he wants to have them reloaded immediately to continue browsing, he has to reload them manually, one by one, or to wait 15 minutes (that doesn't work for me, however)
Comment 6 Andrea 2008-05-20 04:04:38 PDT
Update: just after having submitted the message, I checked again and the feeds were already reloaded (more than 20mins have passed however).
Comment 7 Marco Bonardo [::mak] 2008-05-20 05:58:54 PDT
(In reply to comment #5)
> Let's suppose a user has many feeds (I have 23 subscriptions) and network
> connection falls, if he wants to have them reloaded immediately to continue
> browsing, he has to reload them manually, one by one, or to wait 15 minutes
> (that doesn't work for me, however)

this implies that:
- user is in hurry to see them refreshed (so he can't wait 15 minutes)
- the connection falls before the first update attempt

So the manual reload workaround appear enough at the moment, plus the user can change the expiration time of the livemarks through about:config (notice however that he cannot reduce more than 10 minutes if the feed has failed loading).
So something to look at, but not a severe issue imo.

Comment 8 Marco Bonardo [::mak] 2009-08-12 03:16:29 PDT
*** Bug 440563 has been marked as a duplicate of this bug. ***
Comment 9 Gervase Markham [:gerv] 2009-11-26 06:47:33 PST
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Comment 10 Marco Bonardo [::mak] 2012-02-25 02:41:21 PST
livemarks are not more reloaded in background but on access, so this should be fixed by bug 613588.

Note You need to log in before you can comment on or make changes to this bug.