Closed Bug 4325 Opened 21 years ago Closed 20 years ago

{inc} display:table-cell on HEAD and BODY not very successful

Categories

(Core :: Layout: Tables, defect, P3, minor)

x86
Windows 98
defect

Tracking

()

VERIFIED DUPLICATE of bug 2479

People

(Reporter: ian, Assigned: karnaze)

References

()

Details

(Keywords: css2)

Look at
 http://www.bath.ac.uk/%7Epy8ieh/internet/eviltests/htmlbodyheadrendering2.html

This page attempts to do the this:
   HEAD, BODY { display: table-cell; }
It fails, miserably.

WHAT IS SEEN:
Red box with white border, and the word "Rendering", black on green, below.

WHAT SHOULD BE SEEN:
The document should have two cells, side by side: one on the left, the other on
the right. The one on the left should be red with white writing and a thick
white border. It should contain four dotted lines (it currently only has three)
separated by a blank line, followed by a dotted bordered box containing the
document title, and another dotted bordered box containing the stylesheet.

The dotted borders and lines and the text in the left cell should be white.
The right cell should be teal, with yellow text. The width of the two cells is
left up to the user agent to decide, I think. The right cell should look
similar to the left cell in formatting (except for the colors) -- each box of
text should have a yellow dotted border, and there should be a blank line
between each such box. No box should be nested -- the dotted boxes should
always be distinct from each other.

The cells should be the same height, and they should have grown vertically to
accommodate the BODY text.


See also bug 2479. In fact, 2479 should probably be solved first.
Assignee: troy → karnaze
Component: Layout → HTMLTables
Status: NEW → ASSIGNED
Troy, are there going to be problems mapping <head> and <body> to table-cell
(ignore for the moment that the table frame construction currently would not put
them in the same row)?
No, it should work okay. BODY isn't special anymore, so that shouldn't be a
problem. There may be a problem or two with HTML, but I think it should work
okay
Target Milestone: M7
Moving to M7.
Moving to M9.
Fixing bug 2479 should help this.  Thus adding bug 2479 as a dependency.

However, there are some other issues here too.  I'll try to look at them
tomorrow.  I think the code element is somehow ending the display of the body
element, except it's a little different when I have it in a local file.  I'm
getting four of these each time I load the document:

Assertion: "bad status" (NS_FRAME_IS_COMPLETE(aStatus)) at file
nsScrollFrame.cpp, line 423
The reason there are only three dotted lines, and not four, is that the first
one starts above the top of the table cell.  This can be seen by adding the
style rule:

META:before { content: "name=" attr(name) ", http-equiv=" attr(http-equiv)
", content=" attr(content);}

The contents of the cell are being drawn without regard to the position of the
border or padding.  I though this problem only existed with asymmetric
borders/padding, but I could be wrong...
Summary: display:table-cell on HEAD and BODY not very successful → {css2} {inc} display:table-cell on HEAD and BODY not very successful
[TESTCASE]
I have added an alternate stylesheet to the document called "Show META Contents"
that adds in the rule David mentions above.

After doing that, I discovered that reflowing the document has a very
beneficial effect on the rendering of this page.

The problems that remain after a reflow (which you can trigger by reselecting
the default stylesheet, for example) are mainly due to padding and margins being
incorrectly applied. (Bug 2479 is present too, of course.)

The incremental rendering problems on this page are quite severe, though, and
should probably be solved first.
Perhaps this bug should be assigned to kipp (or troy) for the incremental reflow
problems.
Bug 8912 documents a slightly related crash (requires setting html { display:
table} on this document, but very simplified).
QA Contact: petersen → chrisd
mass move to m14.
Keywords: css2
Migrating from {css2} to css2 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
Target Milestone: M14 → M16
Summary: {css2} {inc} display:table-cell on HEAD and BODY not very successful → {inc} display:table-cell on HEAD and BODY not very successful
Marking a dup, since 2479 has the same testcase.

*** This bug has been marked as a duplicate of 2479 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Verified as a duplicate of bug 2479 and marking as such.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.