All users were logged out of Bugzilla on October 13th, 2018

Problem displaying html{display: table} and body{display:table-cell}

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
20 years ago
18 years ago

People

(Reporter: dbaron, Assigned: karnaze)

Tracking

({css2, testcase, verifyme})

Trunk
x86
Linux
css2, testcase, verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

This is related to, but not the same as, bug 4325.

viewer crashes if I set html {display: table } and body {display: table-cell; }

It must be body, not head - head{display: table-cell} doesn't cause crash.  If I
do the same thing with divs, no crash.

Testcase to be attached.
Created attachment 554 [details]
Test page causing crash

Comment 2

20 years ago
Also see bug 8370 -- "body { display: table; } causes crash" (fixed recently)

Comment 3

20 years ago
Swiping this until I can check if this is the same content sink issue as 8370
Assignee: karnaze → peterl

Updated

20 years ago
Assignee: peterl → karnaze

Comment 4

20 years ago
Crash fixed. Still doesn't display right though...
Summary: Crash caused by html{display: table} and body{display:table-cell} → Problem displaying html{display: table} and body{display:table-cell}
Whiteboard: [TESTCASE]
Updating title and marking as [TESTCASE].

What should happen is that (since HEAD is display: none), you see a one cell
table with "text" in it.

However, being unable to fix this may be excusable.  I'm not sure what the
official rules on changing display on HTML are.  The issues other than that are
covered by bug 4325.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M9
(Assignee)

Updated

20 years ago
Target Milestone: M9 → M11
(Assignee)

Comment 6

20 years ago
Moving to M11
(Assignee)

Comment 7

19 years ago
Moving to M13.
(Assignee)

Updated

19 years ago
Target Milestone: M13 → M14
(Assignee)

Comment 8

19 years ago
mass move to m14.
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
(Assignee)

Comment 10

19 years ago
marking remind.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → REMIND
Target Milestone: M14

Comment 11

19 years ago
Verifying REMIND
Status: RESOLVED → VERIFIED
This works now, doesn't it? David?
Keywords: css2
Whiteboard: [TESTCASE]
Yup.  This works fine now.  Reopening so that I can mark as WORKSFORME.
Status: VERIFIED → REOPENED
Resolution: REMIND → ---
Marking WORKSFORME.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Comment 15

18 years ago
Adding 'verifyme' keyword
Keywords: verifyme

Comment 16

18 years ago
Verifying bug WORKSFORME based on reporter comments
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.