Closed Bug 432877 Opened 15 years ago Closed 15 years ago

Custom recurrence description is broken (regression)

Categories

(Calendar :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: sipaq, Assigned: dbo)

References

Details

(Keywords: regression)

Attachments

(1 file)

With the current nightly (2008-05-07-20) the recurrence description for custom recurrences is broken. It still works in the previous nightly (2008-05-06-18). I get the following information message:

No chrome package registered for chrome://1/locale/sun-calendar-event-dialog.properties

and the following error messages depending on the chosen recurrence range option:

Error: Failed to read 'repeatDetailsRuleDaily3' from 'chrome://calendar/locale/sun-calendar-event-dialog.properties'. Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.formatStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: calGetString :: line 1129"  data: no]
Source File: chrome://calendar/content/calUtils.js
Line: 1136

Error: Failed to read 'repeatDetailsInfinite' from 'chrome://calendar/locale/sun-calendar-event-dialog.properties'. Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.formatStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: calGetString :: line 1129"  data: no]
Source File: chrome://calendar/content/calUtils.js
Line: 1136

Error: Failed to read 'repeatDetailsCount' from 'chrome://calendar/locale/sun-calendar-event-dialog.properties'. Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.formatStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: calGetString :: line 1129"  data: no]
Source File: chrome://calendar/content/calUtils.js
Line: 1136

Error: Failed to read 'repeatDetailsUntil' from 'chrome://calendar/locale/sun-calendar-event-dialog.properties'. Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIStringBundle.formatStringFromName]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: calGetString :: line 1129"  data: no]
Source File: chrome://calendar/content/calUtils.js
Line: 1136

This happens for kinds of recurrences (daily, weekly, monthly, etc.)

Checkins during that time: http://tinyurl.com/6oq4pj
I suspect either bug 428715, bug 430805 or bug 426746.

Steps to reproduce:
1. Open event dialog
2. Choose Repeat -> Custom
3. Define a recurrence and click "OK"
4. There you go!

Recurring events are still properly created, so this is mainly a display issue in the event dialog.
Flags: wanted-calendar0.9?
Regression range:

  Works in Sunbird 0.9pre (2008-05-07-12)
  Fails in Sunbird 0.9pre (2008-05-07-20)

Probably caused by Bug 377761 that changed the behavior of calGetString().
Error is in calendar-dialog-utils.js. 

There are many calls that pass a 4th parameter to calGetString(), e.g. http://mxr.mozilla.org/mozilla1.8/source/calendar/base/content/calendar-dialog-utils.js#415.

This parameter was neither required nor evaluated before. But with the changes made in Bug 377761 it's now interpreted as the optional stringbundle component name.
Keywords: regression
Flags: wanted-calendar0.9? → blocking-calendar0.9+
Attached patch fixSplinter Review
Assignee: nobody → daniel.boelzle
Status: NEW → ASSIGNED
Attachment #320118 - Flags: review?(philipp)
Comment on attachment 320118 [details] [diff] [review]
fix

Uhh..I wonder how that 1 got in there...

r=philipp
Attachment #320118 - Flags: review?(philipp) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH => FIXED.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
I've just tried last build (2008051219) from

ftp://ftp.mozilla.org/pub/calendar/lightning/nightly/latest-mozilla1.8/windows-xpi/

and the bug is still present.
(In reply to comment #8)
> Missed calls for recurrence description:
> http://mxr.mozilla.org/seamonkey/source/calendar/base/content/calendar-dialog-utils.js#563
> 
> Other invalid calls:
> [...]

Now handled in bug 433462.
Status: REOPENED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.