Closed Bug 432957 Opened 16 years ago Closed 16 years ago

Lightning build 2008050820 with network calendars -> Error at startup

Categories

(Calendar :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: Fallen)

Details

STEPS TO REPRODUCE:
===================

- use lightning build 2008050820 with a network calendar, e.g. webdav or WCAP
- start thunderbird/lightning


RESULT:
=======

- Error dialog box at startup

'[JavaScript Error: "this.calendarView has no properties" {file: "chrome://calendar/content/calendar-view-core.xml" line: 247}]' when calling method: [calIOperationListener::onGetResult]

Error console:

Error: [context-id: 6374aaaa-d2c3-40dd-815e-1cfa0619fef5, uri: https://cal-emea.sun.com/, userId=at93795, default calendar]
error: [Exception... "'[JavaScript Error: "this.calendarView has no properties" {file: "chrome://calendar/content/calendar-view-core.xml" line: 247}]' when calling method: [calIOperationListener::onGetResult]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js :: anonymous :: line 543"  data: yes]
stack:
1: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapUtils.js:167] logError
2: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapCalendar.js:113] calWcapCalendar_notifyError_
3: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapCalendar.js:130] calWcapCalendar_notifyError
4: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapCalendarItems.js:1193] getItems_resp
5: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapRequest.js:181] calWcapRequest_execRespFunc

Source File: file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapUtils.js
Line: 167

EXPECTED RESULT:
================

- no errors

REPRODUCIBLE:
=============

- always

Possible root cause is bug 202360
Flags: blocking-calendar0.9+
I added both a webdav and a wcap calendar, but could not reproduce this issue?
I take that back. Will hopefully be fixed with bug 433352.
Status: NEW → ASSIGNED
Fixed by bug 433352

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
Checked in lightning 2008061918 and Sunbird 20080619 -> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.