Day/week view: category color is used for the entire event box

VERIFIED FIXED in 0.9

Status

Calendar
Calendar Views
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: ssitter, Assigned: Fallen)

Tracking

({regression})

unspecified
regression

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051122 Calendar/0.6a1

Steps to Reproduce:
1. Go to Tools -> Options -> Categories and set up a category with color
2. Create an non-all-day event with that category assigned
3. Check the event in day or week view

Actual Results:
The category color is used for the entire event box.

Expected Results:
Event box is displayed in calendar color. Category color is only used for the right border.
Also confirmed for Mozilla1.8 branch. But it seems to happen only for newly created categories.
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
Happens also for existing events and categories as soon as a color is set for a category.
(Assignee)

Comment 3

10 years ago
Created attachment 320882 [details] [diff] [review]
Fix v2

This takes care of

* fixing the category color
* bug 416604 and probably also bug 432957
* Consolidating doubleclick handler for agenda listbox

While looking at this issue, some other problems have emerged regarding the agenda pane.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #320882 - Flags: review?(Berend.Cornelius)
OS: Windows XP → All
Hardware: PC → All

Comment 4

10 years ago
Patch works good and looks fine. You've fixed some bugs and improved the sourcecode at some other parts where it was obviously wrong on the way. Well done!
- category rules are no longer applied to calendar-boxes. So this bug seems to be fixed for me.
- Bug 416604 -> seems to be fixed by your patch. I just noticed that you have a leftover in the "agenda-richlist-item" binding:
><field name="mItem">null</field>;
The declaration of "mItem" is already done in the parent binding 
- bug 432957 could not be reproduced anymore. As the anonymous calendar-month-day-box-item-box inside the allday-richlistitem is not used inside a calendarview it also does not have a "calendarView"-object. So your fix is good enough.

Updated

10 years ago
Attachment #320882 - Flags: review?(Berend.Cornelius) → review+
(Assignee)

Comment 5

10 years ago
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
(Reporter)

Comment 6

10 years ago
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.15pre) Gecko/2008051510 Calendar/0.9pre.

Verified using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051511 Calendar/0.6a1.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.