Category colors are not displayed

VERIFIED FIXED in 0.9

Status

Calendar
Calendar Views
--
major
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Ilja Sekler, Assigned: Fallen)

Tracking

({regression})

unspecified
regression

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008050409 Firefox/3.0pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.15pre) Gecko/20080508 Calendar/0.9pre

Category colors for events and tasks in all views are not displayed anymore. The color is visible only while dragging an event.

Last good: 2008-05-07
First bad: 2008-05-08



Reproducible: Always

Steps to Reproduce:
1. Define a color for a category, different from the color for the calendar
2. Create an event or a task for this category in this calendar

Actual Results:  
The event or task has no color stripe.

Expected Results:  
The colored stripe is visible.


Reproducible also with trunk builds (checkout start: Fr 9. Mai 13:33:39 CEST 2008).

Tested with a single local calendar, there were no other local or remote calendars, if it matters.
(Reporter)

Updated

10 years ago
Keywords: regression
Confirmed regression, culprit: patch from bug 202360.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-calendar0.9?
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 2

10 years ago
Not sure what the issue is, but I'll be taking care.
Assignee: nobody → philipp
(Assignee)

Comment 3

10 years ago
Created attachment 320386 [details] [diff] [review]
Unhide categories

Hiding the categories box is taken care of by a different rule. The hidden="true" is not needed.
Attachment #320386 - Flags: review?(Berend.Cornelius)
Comment on attachment 320386 [details] [diff] [review]
Unhide categories

Stealing review. ;) r=mschroeder
Attachment #320386 - Flags: review?(Berend.Cornelius) → review+
Status: NEW → ASSIGNED
Flags: blocking-calendar0.9?
Duplicate of this bug: 433208
(Assignee)

Comment 6

10 years ago
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9

Comment 7

10 years ago
Checked in lightning build 2008062218 and Sunbird 20080622 -> VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.