If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

facebook.com - Facebook chat is broken by bug 430251 (postMessage dispatches should be async.), which landed on 2008/05/02

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED FIXED
10 years ago
3 years ago

People

(Reporter: Kai Liu, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
This was first reported by users at mZ as a problem that had cropped up very recently:
http://forums.mozillazine.org/viewtopic.php?p=3365817#3365817
http://forums.mozillazine.org/viewtopic.php?p=3366168#3366168

Specifically, the chat application will disconnect after a short period of time (usually within a couple of minutes) with an error message indicating a connection failure.

I decided to take a look at the problem today, and found numerous errors like this in the error console:
----
Error: uncaught exception: [Exception... "Not enough arguments [nsIDOMWindowInternal.postMessage]"  nsresult: "0x80570001 (NS_ERROR_XPC_NOT_ENOUGH_ARGS)"  location: "JS frame :: http://www.facebook.com/home.php? :: anonymous :: line 7"  data: no]
----

Bug 430251 stood out as the most likely culprit, but just to be sure, I checked the tinderbox builds immediately before and after 430251's landing (20080502_1115 & 20080502_1313), and the problem was not present before but was present after.

I'm not entirely sure if this is a problem of Facebook needing to update their chat application for this new behavior (which they may be oblivious to, given how recently it landed) or if there is a bug in the implementation, but I'm going to go with the former for now, which is why I'm filing this in TE.
I have contacts at facebook, so if this is indeed a TE issue, I can point the right people at this bug. Waldo, thoughts?
It's TE.  There are real production sites seriously using functionality that's not in a single shipping browser and is just barely (barely) standardized?  Madness.

Comment 3

10 years ago
TE seems to have been successful.  They are reportedly working on a fix.
(Reporter)

Updated

10 years ago
Duplicate of this bug: 434677

Comment 5

10 years ago
seems to be fixed now.

Comment 6

10 years ago
Confirmed as fixed starting evening of May 20th.
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 7

9 years ago
Well it's happenings to me, few minutes and failure to connect to Facebook chat, I'll then just refresh the page and its a quick fix for another few minutes...
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.