[Yahoo Mail Notifier] Could not convert JavaScript argument arg 0 [nsISupports.QueryInterface]

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Administration
RESOLVED FIXED
10 years ago
2 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008051218 Firefox/3.0pre

Steps to reproduce:
-> Install the Yahoo Mail Notifier https://addons.mozilla.org/en-US/firefox/addon/1264
-> Configure the Mail Notifier with your Yahoo Mail Account (make sure there are some mails in this account) and save the password
-> Restart Firefox 
-> JS Error:

* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "Could not convert JavaScript argument arg 0 [nsISupports.QueryInterface]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: file:///Users/carstenbook/Library/Application%20Support/Firefox/Profiles/rn08739c.default/extensions/%7B89f8dde0-010a-11da-8cd6-0800200c9a66%7D/platform/Darwin/components/ymNotifierGrowlNotifications.js :: observer :: line 41"  data: no]
I found the problem.  Yahoo Mail Notifier will use the Growl Notifications addon if it's available, but I never checked to see if it was available in my component before trying to use it.  

I never tested this myself since I don't have a Mac, but the person who tested it never had an issue (probably because he had the Growl Notification addon installed).

The error won't cause problems, but I'll fix it for my next release.  I'll have to make changes anyway because Growl support is integrated into Firefox 3, so the addon won't be required.

Thanks for the heads up.
Created attachment 320616 [details]
Updated addon to get rid of error.

I just noticed that this was filed on the Mozilla bug site.  I'm not sure that's the correct place to file a bug report for an addons.

In any case since it's here and I don't have a Mac, can you please test this updated extension to see if it solves the problem.
(Reporter)

Comment 3

10 years ago
Yes, this new Version fixes the problem for me, i don't see the error message anymore - thanks Michael
Okay good.

I don't have the ability to edit this bug (or take it).  Can someone with permission be close this out?
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)
> Okay good.
> 
> I don't have the ability to edit this bug (or take it).  Can someone with
> permission be close this out?
> 

Closing as fixed :) 
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Component: Add-ons → Administration
QA Contact: add-ons → administration
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.