Spell check: Using "Remove" or "Replace" buttons don't work in personal dictionary dialog

VERIFIED INVALID

Status

()

Core
Editor
P4
normal
VERIFIED INVALID
17 years ago
15 years ago

People

(Reporter: rubydoo123, Assigned: kinmoz)

Tracking

({helpwanted})

Trunk
mozilla1.2alpha
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [spellcheck]EDITORBASE+)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Selected added word in the personal dictionary, selected delete and the word was 
not deleted.

Steps to reproduce:
1. open either an existing page or new page. If a new page, enter several lines 
of text, making sure to add some unique words such as Netscape or AOL.
2. select spelling from toolbar or menu
3. when the unique word os found and is displayed in the text field of the spell 
check dialog, select add. Complete the spell check session.
4. Relaunch spell check and select Edit from the dialog
5. In the edit personal dictionary dialog, select the word you just added and 
select delete.

What happens: the word is not deleted
(Reporter)

Comment 1

17 years ago
setting to m17
Target Milestone: --- → M17
(Assignee)

Comment 2

17 years ago
Accepting bug.
Status: NEW → ASSIGNED
(Reporter)

Comment 3

17 years ago
needs to be fixed for beta3
Keywords: correctness, nsbeta3
Target Milestone: M17 → M18
(Reporter)

Comment 4

17 years ago
setting to nsbeta3+
Whiteboard: nsbeta3+
(Reporter)

Comment 5

17 years ago
setting priority in status whiteboard
Priority: P3 → P4
Whiteboard: nsbeta3+ → [nsbeta3+][p:4]

Comment 6

17 years ago
PDT downloading to [nsbeta2-]
Whiteboard: [nsbeta3+][p:4] → [nsbeta3+][p:4][minus]
(Reporter)

Comment 7

17 years ago
hopefully the user will be able to edit the personal dictionary with another 
application

setting to minus, moving to future and adding helpwanted
Keywords: helpwanted
Whiteboard: [nsbeta3+][p:4][minus] → [nsbeta3-][p:4][minus]
Target Milestone: M18 → Future

Comment 8

17 years ago
*** Bug 73268 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Changed Summary for better searching.
I think this should be reevaluated for 0.9.1
Summary: Deleting from personal dictionary doesn't work → Using "Remove" button to delete from personal dictionary doesn't work
Target Milestone: Future → mozilla0.9.1
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2
(Reporter)

Updated

16 years ago
Keywords: nsbeta3
Whiteboard: [nsbeta3-][p:4][minus] → [spellcheck]
Target Milestone: mozilla0.9.2 → mozilla1.0

Comment 10

16 years ago
Confirming Spell`s User Dictionary behaviour still exists in Composer build
20010903.

While testing Spell Check feature using a rather long pre-saved document,
created a new Personal Dictionary list by adding approximately 145 odd
words--some mispelled, even.  Could empty, though not permanently delete, the
Personal Dictionary list, just as described above.  After seemingly have
unloadeded the entire list under ``Words in dictionary:,'' by navigating
[Spell], [Edit] Personal Dictionary, highlighting the first word in the list
[Remove], [Remove], [Remove], ... [Close], the list will return every time.

Completely exiting the software altogether has no additional effect.  The list
persists.


Note: Please see also, where the exact issue appears in (Mail) Composer Spell
Check User Dictionary, as originally indicated in Bug 58901.  The identical
list, apparently ``emptied,'' magically appears untouched when Personal
Dictionary is reopened.

*** Bug 58901 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

16 years ago
Bulk move of mozilla1.0 bugs to mozilla.1.0.1. I will try to pull some of these
back in if I can.
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 13

16 years ago
Shouldn't Platform/OS be set to all/all on this bug?

Updated

15 years ago
Summary: Using "Remove" button to delete from personal dictionary doesn't work → Spell check: Using "Remove" or "Replace" buttons don't work in personal dictionary dialog

Comment 14

15 years ago
*** Bug 152546 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
I think this should get some attention! Marking editorbase.
Whiteboard: [spellcheck] → [spellcheck]EDITORBASE

Comment 16

15 years ago
The reason this hasn't been fixed a long time ago is explained by kin:
"It's a bug in the INSO codethere's a bit that's preventing things from being
removed I don't see how (in the INSO API)to cause that bit to get set/unset"

Comment 17

15 years ago
Created attachment 88199 [details] [diff] [review]
Workaround patch v1 for NS spellcheck module

This patch is contingent on adding ResetPersonalDictionary to NS spellcheck
code 
as well (see bugzilla bug 127704).
But to do this right in mozilla space, we probably should have an overlay that
uses code in this patch only when using the INSO spell checker.
I hope the mozdev spellchecker doesn't have this problem and doesn't have to
use this hack.

Comment 18

15 years ago
In last comment, adding "ResetPersonalDictionary()" to NS code is
http://bugscape.netscape.com/show_bug.cgi?id=16869 for NS people to look at.
(Assignee)

Updated

15 years ago
Target Milestone: mozilla1.0.1 → mozilla1.2alpha

Comment 19

15 years ago
Nominating for Buffy. Workaround is to close and re-open Netscape and deleted
items will no longer show. 
Keywords: nsbeta1

Updated

15 years ago
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [spellcheck]EDITORBASE → [spellcheck]EDITORBASE+
Syd: Can someone on the composer team take this one? Kin's overloaded. Thanks.
Assignee: kin → syd
Status: ASSIGNED → NEW

Comment 21

15 years ago
i'll look at this a bit
Assignee: syd → cmanske

Comment 22

15 years ago
-->kin
Assignee: cmanske → kin
OS: Windows 98 → All
Hardware: PC → All
(Assignee)

Comment 23

15 years ago
This turned out to be a bug in the 3rd party spellchecker Netscape uses.
(bugscape id 13713)

Resolving this bug as invalid since it's not front end related.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 24

15 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.