ONDBLCLICK event not functioning on BUTTON element.

VERIFIED DUPLICATE of bug 29473

Status

()

P3
normal
VERIFIED DUPLICATE of bug 29473
19 years ago
19 years ago

People

(Reporter: chrispetersen, Assigned: joki)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
build: 2000062108
Platform: All
Expected Result: Double clicking on button element should execute a ondblclick 
event. This should result in a alert dialog to be displayed.
What I got: No alert dialog is displayed after double clicking on button.

Steps to reproduce:
1) Open the url specified.
2) Double click on button.
3) No dialog appears.
4) This same test case works in Mac IE 5 and Win IE 5.5.
(Reporter)

Updated

19 years ago
QA Contact: janc → petersen
(Assignee)

Comment 1

19 years ago
Marking dupe of 29473.  Though in general doubleclicks should be handled via the 
new DOM Level 2 method of checking the event.detail to determine the clickcount.  
This allows clickcount determination for mousedown, mouseup, and click as well 
as support for more than 2 clicks.

*** This bug has been marked as a duplicate of 29473 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.