The groupbox control doesn't respect windows theme

RESOLVED DUPLICATE of bug 390734

Status

()

--
trivial
RESOLVED DUPLICATE of bug 390734
10 years ago
10 years ago

People

(Reporter: daf.bugzilla, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

Currently Firefox 3 Strata theme doesn't make groupbox controls respect windows theme like Firefox 2 does.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

10 years ago
Created attachment 320780 [details]
Image Showing the issue
Dup of Bug 349859
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 349859

Comment 4

10 years ago
Not really a dupe of bug 349859 because that was about making it look native for Classic.  Because of the way that was done (using the windows-default-theme metric instead of the (unfortunately non-existent) windows-is-themed metric), that "regressed" the the appearance of the groupbox for third-party styles.

But it wasn't really a regression, as styled Windows didn't use use native styling, either: it just drew a single-width rounded box which happened to appear native for any Luna, Royale, etc. (but not Aero!), so if the reporter here happened to use a style that didn't follow the Luna look, it would have looked wrong either way.  Bug 349859 really should have been morphed to a classic-only bug and resolved, and another bug kept open for the general-case fix.

I think it's probably best to morph & resolve bug 349859, use this bug into a general bug for the native widget work that would be required to properly handle groupboxes, and set bug 390734 and bug 236107 to depend on this bug.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

10 years ago
(Unless you want to do the native widget stuff in bug 349859, but my understanding was that it was best in cases like this to resolve the old bug and use a new bug, to avoid confusion.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Updated

10 years ago
Blocks: 236107, 390734
(Reporter)

Comment 6

10 years ago
I never noticed that the groupbox wasn't actually following Windows Styles theme. Besides the issue here I've noticed other diferences like the top border of the tab control and the new listbox (no idea what happened there).

Is there any tracker bug for these kind of issues?
Version: Trunk → unspecified

Comment 7

10 years ago
(In reply to comment #6)
> Is there any tracker bug for these kind of issues?
> 

Not that I know of.  There are a number of theme issues because not everything is rendered natively; many of these issues have been around for a long time, and with each release, more and more of them get addressed.
Version: unspecified → Trunk

Updated

10 years ago
Component: Theme → XUL Widgets
Product: Firefox → Toolkit
QA Contact: theme → xul.widgets

Updated

10 years ago
Component: XUL Widgets → Widget: Win32
Product: Toolkit → Core
QA Contact: xul.widgets → win32

Updated

10 years ago
Blocks: 349859

Comment 8

10 years ago
We really need groupboxes to go through nsITheme/-moz-appearance, IMHO.

Updated

10 years ago
No longer blocks: 390734

Updated

10 years ago
No longer blocks: 236107

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390734
You need to log in before you can comment on or make changes to this bug.