Closed Bug 349859 Opened 15 years ago Closed 12 years ago

groupboxes don't follow native theming

Categories

(Core :: Widget, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: kairo, Assigned: neil)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

In current [win|gnome]stripe theme, groupboxes are always in a flat, rounded, XP Luna style, while they 1) should follow WinClassic when native theming can't be picked up if bug 313388 is still the way we want to go, and 2) they should follow the native theme where possible.

1) is easy to do, it's just some style rules in toolkit/themes/winstripe/global/groupbox.css - I'm sure some people would be upset once again though, just like they were in bug 313388

2) is probably the harder part, but it's also the part I'm completely unable to look on as I don't nearly understand any of the code.
Robert, this bug looks like a dupe of bug 236107.
Henrik:
Actually not, bug 236107 looks more like a subset of this to me, it only talks about the color of the caption, while this bug is about appearance of the whole groupbox.
for 2) We should probably be using GetThemeColor to get the BorderColorHint of Groupbox. (on windows at least, I don't know about the other platforms)
Using the new :-moz-system-metric(windows-default-theme) selector, so that the Luna/Aero look only applies under, well, Luna or Aero ;-)
Attachment #314584 - Flags: review?(mconnor)
Comment on attachment 314584 [details] [diff] [review]
Make groupboxes square again on Windows 2000

This should be pretty safe.
Attachment #314584 - Flags: review?(mconnor)
Attachment #314584 - Flags: review+
Attachment #314584 - Flags: approval1.9+
Checked in attachment 314584 [details] [diff] [review], although I don't think this is a complete fix.
Note that bug 403753 fixed this for Linux. A complete fix would probably involve native theming, on Windows at least.
Component: Themes → Widget: Win32
Depends on: 403753
QA Contact: themes → win32
Currently group boxes have the correct look for both Windows XP style (rounded) and Windows Classic style (square).

But they have the incorrect look for Media Center style (square, while they should be rounded).  Is Firefox going to get back the correct rounded group-boxes for Media Center style?
Whiteboard: [not needed for 1.9]
Duplicate of this bug: 433566
Comment 0 in this bug talked about making groupboxes look native on Windows Classic, and a patch to do precisely that has been checked in.  Any objections to me marking this bug resolved?  Bug 433566 can be used as the general implement-groupboxes-in-nsNativeThemeWin.cpp bug.
Sounds reasonable. Assigning to Neil and marking as FIXED (since he fixed it). (Hopefully Neil is OK with this.)
Assignee: nobody → neil
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Summary: groupboxes don't follow native theming → groupboxes don't follow native theming on Windows Classic
Whiteboard: [not needed for 1.9]
Reopening, as I filed it and I _intended_ to have it as exactly what the summary said, WinClassic was merely an example of where we aren't following it. We also should pull it from nsITheme on other themes or even Linux, for example, not hardcoding an appearance in the theme but coding it on nsITheme and possibly enabling us to pull in, say, Qt theme groupbox style if we ever support Qt, as we are already pulling stuff from nsITheme via -moz-appearance and not hardcoding stuff in the CSS theme, which is IMHO plainly wrong.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: groupboxes don't follow native theming on Windows Classic → groupboxes don't follow native theming
Assignee: neil → nobody
Status: REOPENED → NEW
Component: Widget: Win32 → Widget
QA Contact: win32 → general
Depends on: 433566
(In reply to comment #0)
> In current [win|gnome]stripe theme, groupboxes are always in a flat, rounded,
> XP Luna style, while they 1) should follow WinClassic when native theming can't
> be picked up if bug 313388 is still the way we want to go,

This has been fixed here.

> and 2) they should
> follow the native theme where possible.

There's now bug 433566 for that.
Assignee: nobody → neil
Status: NEW → RESOLVED
Closed: 13 years ago12 years ago
Resolution: --- → FIXED
Blocks: 482972
You need to log in before you can comment on or make changes to this bug.