If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Context menu gets borked when there is no search file in "FX/searchengines/"

VERIFIED DUPLICATE of bug 342643

Status

()

Firefox
Menus
VERIFIED DUPLICATE of bug 342643
10 years ago
10 years ago

People

(Reporter: Konrad Kosmowski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

When I delete all XML files from "FX/searchengines" folder the context menu on webpages displays lots (like 30+) entries.

Reproducible: Always

Steps to Reproduce:
1. Close the browser.
2. Delete all XML files in "FX/searchengines" (installation) folder.
3. Open the browser.
4. Open a webpage select some text, and right click on it.
Actual Results:  
Menu with lots of unrelated entries shows up like in here:
http://home.kosmosik.net/always/fx_borked.png


Expected Results:  
Normal menu should show up like in here:
http://home.kosmosik.net/always/fx_ok.png
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 342643
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.