Closed Bug 342643 Opened 13 years ago Closed 7 years ago

Too long (or wrong) context-menu when all search engines are deleted

Categories

(Firefox :: Search, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED WONTFIX

People

(Reporter: ria.klaassen, Unassigned)

References

Details

(Keywords: helpwanted, regression)

I discovered this first when Bug 341981 was filed but not yet repaired. When I deleted the search engines in the application directory the context-menus became too long (too many items in it).
Now that the bug is repaired, also this seems to be fixed, although the problem still shows up when all search engines, also in the profile, are deleted. I tried this out in order to fight bug 341850.

Steps to reproduce:
- Delete both folders searchplugins in the application dir and profile
- Start Firefox, select some word and right-click
- Result: menu too long with all possible items in it

Maybe this is edge case, I don't know. The act to delete all plugins in the app dir is not uncommon, and when you happen to make also a new profile at that moment, the problem will be visible.
Regression between 1.9a1_2006031620 and 1.9a1_2006031704.
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2006-03-16+19%3A00&maxdate=2006-03-17+05%3A00
Not clear what bug could have caused this.
It must be a search engine bug, presumably Bug 317107, because every time when I call the context-menu I see an error appear:

Error: ss.currentEngine has no properties
Source File: chrome://browser/content/browser.js
Line: 4469

And because I also see it in branch.
Blocks: 317107
Keywords: regression
Yeah, I know what the problem is, just need to null check currentEngine/defaultEngine.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Hm, I have no idea why I marked this WORKSFORME. I just checked a 13 Oct 2006 build but this time the bug is still present. I must have done something that caused a different result.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
This is less of a problem after the patch for bug 335822, which made it impossible to delete all the engines with the UI.
Severity: normal → minor
Status: REOPENED → NEW
Keywords: helpwanted
OS: Windows XP → All
Hardware: PC → All
Duplicate of this bug: 383707
Duplicate of this bug: 433586
Duplicate of this bug: 448874
If you select a word you'll see a long context menu, but after a right click somewhere in the page it can't be reproduced anymore, so this explains comment 4.
If you opened the normal context menu once and then try to reproduce this (select text, open the context menu), the normal (wrong) context menu will be shown. The normal context menu is short (as described in #9 & #4). It's the wrong menu though.
Yeah, I checked indeed only the length of the menus; not the contents. Updating summary.
Summary: Too long context-menu when all search engines are deleted → Too long (or wrong) context-menu when all search engines are deleted
This bug still exists in Firefox 4 Beta 9 - (Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9)

I ended up with no search engines setup after upgrading from Firefox 4 beta 7 to beta 8. I'm not sure how that occurred, and I don't think it's relevant to this bug. However, once I was in this state, my context menu became messed up per the above comments. 

Today, I finally searched for a bug thinking to report the issue, I found this bug and it seems to match exactly what was occurring. I reset my search engine list back to the defaults (Manage Search Engines | Restore Defaults). Once I did that, my context menu's started behaving normally again. 

As the above comments say, now that I've restored my search engines I can't get back to a "no search engine" state because the GUI doesn't allow deleting the last engine.
(In reply to comment #12)
> I ended up with no search engines setup after upgrading from Firefox 4 beta 7
> to beta 8. I'm not sure how that occurred, and I don't think it's relevant to
> this bug. However, once I was in this state, my context menu became messed up
> per the above comments. 

That has been caused by testpilot. See bug 620672.
It doesn't look possible on MacOSX to delete the default search engine. While I can remove all but Google, it isn't removed by deleting the profile plugins and the searchplugins folder.
Whiteboard: [wontfix?]
That's the state of things since comment 5, yeah. The STR at this point involve deleting the search plugins from the application directory. That's not really a supported action (or one we should try to deal with).
Status: NEW → RESOLVED
Closed: 13 years ago7 years ago
Resolution: --- → WONTFIX
Whiteboard: [wontfix?]
You need to log in before you can comment on or make changes to this bug.