All users were logged out of Bugzilla on October 13th, 2018

DNS timeout caused by profile locking

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
11 years ago
3 years ago

People

(Reporter: wolfiR, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
profile locking shouldn't use PR_GetHostByName()

There are systems which can't resolve their own hostname (which could be interpreted as broken system configuration but nevertheless it's a fact).
That causes long startup timeouts for Firefox (or other mozilla based applications).

I wonder if we really need to set the old-style symlink lock if the fcntl lock is successful (Mac is not doing it in that case for example).
If so, we shouldn't get the local IP address via DNS.

The old style symlink lock is in many cases pretty useless anyway since on many Linux systems it resolves to 127.0.0.1 or 127.0.0.2 which makes the IP comparison for a shared home useless.
(Reporter)

Comment 1

11 years ago
(In reply to comment #0)
> If so, we shouldn't get the local IP address via DNS.

getifaddrs() should be available on current Linux systems. (No idea when it got available in glibc though.)
I couldn't find getifaddrs() as supported through any NSPR function.
So could I use getifaddrs directly for a candidate patch?

Comment 2

11 years ago
NSPR uses getifaddrs internally but doesn't expose it.  I'm
interested in adding an NSPR function that returns the IP
adddresses of the localhost, but haven't got around to that.
(Reporter)

Updated

8 years ago
Duplicate of this bug: 533672

Updated

3 years ago
Duplicate of this bug: 1189705

Comment 5

3 years ago
This bug is filed in a bugzilla component related to pre-Firefox code which no longer exists. I believe it is no longer relevant and I am therefore closing it INCOMPLETE.

If you believe that this bug is still valid and needs to be fixed, please reopen it and move it to the Toolkit:Startup and Profile System product/component.
No longer blocks: 1243899
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

3 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.