Can install add-ons into RC1 whose maxversion is 3.0b5pre

VERIFIED DUPLICATE of bug 433371

Status

()

Toolkit
Add-ons Manager
--
critical
VERIFIED DUPLICATE of bug 433371
10 years ago
10 years ago

People

(Reporter: MarcoZ, Unassigned)

Tracking

Trunk
mozilla1.9
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

When testing the accessibility for Add-Ons Manager on both Windows and Linux, I found that I could install add-ons into the Windows version of 3.0RC1 that I could not install into the Linux version.

STR:
1. On Linux, open Firefox 3 RC1.
2. Go to Tools/Add-Ons.
3. On the Get Add-Ons page, look in the list of recommended add-ons. I'm seeing ScribeFire, Download Statusbar, and FoxyProxy.
4. Right-Click Download Statusbar and choose "Add to Firefox".
5. After the countdown, click "Install now".

Result: Add-On will not be installed, complains that it is not compatible with Firefox 3.0.

6. Repeat Steps 1 through 5 on Windows.

Expected: Same result.
Actual: The add-on installs fine, Firefox prompts you to restart, and after the restart, the add-on is available.

7. Open the URL given above, and download the XPI by right-clicking "Add to Firefox".
8. Look in the XPI. The install.rdf file shows the max version being 3.0b5pre!


Additionally, I am also seeing that Adblock Plus, ScribeFire, IETab are also active in my 3.0RC1 installation. I cannot install any of these in Linux with the same "Incompatible version" error message, yet they are active on Windows.
Flags: blocking-firefox3?
All of those add-ons should install correctly on Firefox 3 so this would be a fault with the Linux version not detecting the compatibility information correctly.
OS: Windows XP → Linux
Dave, I don't really think so. As Marco told me on IRC it also happens when installing such an add-on locally. Having a look inside the install.rdf shows me following:

<!-- Target Application this extension can install into, 
        with minimum and maximum supported versions. --> 
    <em:targetApplication>
      <Description>
        <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
        <em:minVersion>2.0</em:minVersion>
        <em:maxVersion>3.0b5pre</em:maxVersion>
      </Description>
    </em:targetApplication>

So this add-on shouldn't be compatible with Firefox 3 RC1, right? In that case no installation should be possible.
My Linux is an ubuntu 8.04, and as mossop asked, I did run the Ubuntu version of Firefox once before I ran RC1. I used that version to download RC1 as a matter of fact.
(In reply to comment #2)
> Dave, I don't really think so. As Marco told me on IRC it also happens when
> installing such an add-on locally. Having a look inside the install.rdf shows
> me following:
> 
> <!-- Target Application this extension can install into, 
>         with minimum and maximum supported versions. --> 
>     <em:targetApplication>
>       <Description>
>         <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
>         <em:minVersion>2.0</em:minVersion>
>         <em:maxVersion>3.0b5pre</em:maxVersion>
>       </Description>
>     </em:targetApplication>
> 
> So this add-on shouldn't be compatible with Firefox 3 RC1, right? In that case
> no installation should be possible.
> 

When an add-on appears to be incompatible we request updated compatibility information from AMO. In the case of all the add-ons listed in this bug AMO is saying they are compatible with 3.0.*.
From talking on IRC I am pretty confident that this is due to bug 433371. Marco's profile showed signs of Ubuntu's language packs which shouldn't have been there and after recreating the extensions datasources installation succeeded.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-firefox3?
Resolution: --- → DUPLICATE
Duplicate of bug: 433371
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.