Closed Bug 434155 Opened 12 years ago Closed 11 years ago

Help -> Check for Updates does not verify add-on compatibility

Categories

(Toolkit :: Application Update, defect)

1.9.0 Branch
Other
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla1.9.1b2

People

(Reporter: tim.bogus, Assigned: rstrong)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0

When upgrading through through Help > Check for Updates...  Firefox (Software Update) shows the inverse list of incompatible extensions under the heading: 

"the following items are not compatible with this update to Firefox and will be disabled when it is installed:"

It then shows me a list of four extensions that will be "incompatible".

I choose 'close' and continue.

When the update program - 'Firefox Update' - runs it shows a similar message:

"The following add-ons are not compatible with this version of Firefox and have been disabled:"

Instead of showing the four it showed originally - it shows the true inverse of those four extensions - the ones that truly incompatible.

This has happened everytime I've upgraded with FF3 since Beta 2.

(Note: this is my first bug request - be easy on me if I didn't get the right terminology.)

Reproducible: Always

Steps to Reproduce:
1.new version is released
2.Go Help > Check for updates...
3.Go through the wizard
Actual Results:  
it gives an inverse account of the extensions that are incompatible with the next version of FF.

Expected Results:  
it should give the true representation of those extensions that are incompatible - not the ones that are compatible!
Version: unspecified → 3.0 Branch
Component: Installer → Software Update
QA Contact: installer → software.update
What are the actual extensions you are seeing this with, have you used any method for overriding the compatibility of your extensions like Nightly Tester Tools or by setting the extensions.checkCompatibility preference?
I've added screenshots for reference.

All extensions are extensions available via AMO - with the exception of 1Password and Delicious, which are manual installs.

Is there anyway to generate a list of all my extensions in FF?
Duplicate of this bug: 434162
This is a fault with the add-on update check performed by the software update service
Assignee: nobody → dtownsend
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 427486
Ok the bug here is that the update UI does not perform an add-on update check before warning about potentially incompatible add-ons (it does in the background, just not when forcing an app update check). There is also a related failure with the update check performed in the back filed as bug 434465.
Summary: firefox/software update shows 'wrong' list of incompatible extensions when upgrading → Help - check for updates does not very add-on compatibility
Summary: Help - check for updates does not very add-on compatibility → Help -> Check for Updates does not verify add-on compatibility
Assignee: dtownsend → nobody
Product: Firefox → Toolkit
This should be fixed by bug 324121 and at the very least depends on it.
Depends on: 324121
we'll need tests added
Flags: in-testsuite?
Flags: in-litmus?
As far as the results returned by the extension mgr. code there are unit tests in bug 324121. I'll be adding other tests where possible and time permits in bug 324121 and I doubt I will do anything in this bug since this bug represents only one of several problems with the app update code that is being addressed in bug 324121.
tests exist in bug 324121.
Flags: in-testsuite? → in-testsuite-
Fixed by the checkin of bug 324121.
Assignee: nobody → robert.bugzilla
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1b2
litmus testcases 

https://litmus.mozilla.org/show_test.cgi?id=6719

and

https://litmus.mozilla.org/show_test.cgi?id=6718


take care of this bug in their steps to perform section.


oh, and verified FIXED on builds:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2pre)
Gecko/20090722 Shiretoko/3.5.2pre ID:20090722035056

and

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre)
Gecko/20090723 Minefield/3.6a1pre ID:20090723134652
Status: RESOLVED → VERIFIED
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.