test_bug430120.js asserts in debug builds, makes xpcshell tests fail

RESOLVED FIXED

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Waldo, Assigned: Nickolay_Ponomarev)

Tracking

({assertion})

Trunk
x86
Mac OS X
assertion
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
This prevents me from running all the tests to make sure a patch I've written doesn't regress anything.

Log is as follows:


../../../../_tests/xpcshell-simple/test_extensionmanager/unit/test_bug430120.js: /Users/jwalden/moz/2/tools/test-harness/xpcshell-simple/test_all.sh: line 129:  7384 Abort trap              NATIVE_TOPSRCDIR="$native_topsrcdir" TOPSRCDIR="$topsrcdir" $xpcshell -s $headfiles -f $t $tailfiles 2>$t.log 1>&2
FAIL
../../../../_tests/xpcshell-simple/test_extensionmanager/unit/test_bug430120.js.log:
>>>>>>>
*** test pending
*** test pending
*** test finished
*** running event loop
*** test finished
*** exiting
*** Blocklist::onXMLLoad: there was an error during load
*** PASS ***
2008-05-17 19:03:14.516 xpcshell[7384]: DebugAssert: Third Party Client: result == 0  [-47 = fBsyErr] FSDeleteContainerContents [/Users/jwalden/moz/2/xpcom/MoreFiles/MoreFilesX.c:1580]
WARNING: nsExceptionService ignoring thread destruction after shutdown: file /Users/jwalden/moz/2/xpcom/base/nsExceptionService.cpp, line 194
###!!! ASSERTION: XPConnect is being called on a scope without a 'Components' property!: 'Error', file /Users/jwalden/moz/2/js/src/xpconnect/src/xpcwrappednativescope.cpp, line 765
DEBUG_CheckForComponentsInScope(XPCCallContext&, JSObject*, int) (/Users/jwalden/moz/2/js/src/xpconnect/src/xpcwrappednativescope.cpp:765)
XPCWrappedNativeScope::FindInJSObjectScope(XPCCallContext&, JSObject*, int) (/Users/jwalden/moz/2/js/src/xpconnect/src/xpcwrappednativescope.cpp:804)
GetContextFromObject(JSObject*) (/Users/jwalden/moz/2/js/src/xpconnect/src/xpcwrappedjsclass.cpp:520)
nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJS*, unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*) (/Users/jwalden/moz/2/js/src/xpconnect/src/xpcwrappedjsclass.cpp:1130)
nsXPCWrappedJS::CallMethod(unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*) (/Users/jwalden/moz/2/js/src/xpconnect/src/xpcwrappedjs.cpp:559)
PrepareAndDispatch(nsXPTCStubBase*, unsigned int, unsigned int*) (/Users/jwalden/moz/2/xpcom/reflect/xptcall/src/md/unix/xptcstubs_unixish_x86.cpp:93)
nsXPTCStubBase::Stub4() (/Users/jwalden/moz/builds/2/xpcom/reflect/xptcall/src/md/unix/../../../../../../dist/include/xpcom/xptcstubsdef.inc:2)
NS_InvokeByIndex_P (/Users/jwalden/moz/2/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_unixish_x86.cpp:179)
nsProxyObjectCallInfo::Run() (/Users/jwalden/moz/2/xpcom/proxy/src/nsProxyEvent.cpp:181)
nsThread::ProcessNextEvent(int, int*) (/Users/jwalden/moz/2/xpcom/threads/nsThread.cpp:510)
NS_ProcessNextEvent_P(nsIThread*, int) (/Users/jwalden/moz/builds/2/xpcom/build/nsThreadUtils.cpp:227)
nsThread::Shutdown() (/Users/jwalden/moz/2/xpcom/threads/nsThread.cpp:465)
nsSocketTransportService::Shutdown() (/Users/jwalden/moz/2/netwerk/base/src/nsSocketTransportService2.cpp:445)
nsIOService::SetOffline(int) (/Users/jwalden/moz/2/netwerk/base/src/nsIOService.cpp:617)
nsIOService::Observe(nsISupports*, char const*, unsigned short const*) (/Users/jwalden/moz/2/netwerk/base/src/nsIOService.cpp:788)
nsObserverList::NotifyObservers(nsISupports*, char const*, unsigned short const*) (/Users/jwalden/moz/2/xpcom/ds/nsObserverList.cpp:128)
nsObserverService::NotifyObservers(nsISupports*, char const*, unsigned short const*) (/Users/jwalden/moz/2/xpcom/ds/nsObserverService.cpp:181)
NS_ShutdownXPCOM_P (/Users/jwalden/moz/2/xpcom/build/nsXPComInit.cpp:724)
NS_ShutdownXPCOM (/Users/jwalden/moz/2/xpcom/stub/nsXPComStub.cpp:175)
main (/Users/jwalden/moz/2/js/src/xpconnect/shell/xpcshell.cpp:1477)
_start (/Users/jwalden/moz/2/js/src/xpconnect/shell/xpcshell.cpp:114)
start (/Users/jwalden/moz/2/js/src/xpconnect/shell/xpcshell.cpp:114)

<<<<<<<
Isn't this a dupe of bug #428078?
(In reply to comment #1)
> Isn't this a dupe of bug #428078?
> 

Since it is for a different test and gives a different error ... no.
Assignee: nobody → dtownsend
(Assignee)

Comment 3

10 years ago
This is due to missing httpserver.stop() call.
Blocks: 430120
Flags: in-testsuite-
(Assignee)

Comment 4

10 years ago
Created attachment 325176 [details] [diff] [review]
patch

The test still leaks an nsStringBuffer (doesn't leak it without the last fireTimer call), but it's a separate issue.
Assignee: dtownsend → asqueella
Status: NEW → ASSIGNED
Attachment #325176 - Flags: review?(dtownsend)
(Assignee)

Comment 5

10 years ago
Created attachment 325177 [details] [diff] [review]
patch

Er, the right one.
Attachment #325176 - Attachment is obsolete: true
Attachment #325177 - Flags: review?(dtownsend)
Attachment #325176 - Flags: review?(dtownsend)

Updated

10 years ago
Attachment #325177 - Flags: review?(dtownsend) → review+
(Assignee)

Comment 6

10 years ago
Checked into mozilla-central: http://hg.mozilla.org/index.cgi/mozilla-central/rev/8e107e64a99e
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.