Firefox 3.0 RC1 on OS X high idle CPU usage (XRE_GetFileFromPath?)

RESOLVED FIXED in Firefox 3

Status

()

RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: wd, Unassigned)

Tracking

unspecified
Firefox 3
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 432028])

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0

Since updating from Firefox 3.0b5 to 3.0 RC1 on Mac OS X, I have noticed high CPU usage when Firefox is "idle" (only one tab open, on Firefox start page).

With Firefox 3.0b5, the CPU usage was less than 1%
Since upgrading to RC1, CPU usage is between 15-20%

I have the Forecastfox Enhanced add-on.

Reproducible: Always

Steps to Reproduce:
1.Install Firefox 3.0 RC1 on Mac OS X (Tiger)
2.Install Forecastfox Enhanced Add-on
3.Open Firefox to start page only
4.Observe CPU usage with Activity Monitor
Actual Results:  
15% or more CPU usage

Expected Results:  
less than 1% CPU usage

I cannot reproduce this behavior on Windows.  It appears to be a regression that only affects OS X.

The details from Activity Monitor for RC1:

Total number in stack (recursive counted multiple, when >=5):
        69       XRE_GetFileFromPath
        19       JSD_GetValueForObject
        18       JSJ_RegisterLiveConnectFactory
        17       NS_GetComponentRegistrar_P
        16       CRMF_EncodeCertReqMessages
        9       GetSecurityContext(JNIEnv_*, nsISecurityContext**)
        8       _pthread_body
        8       mach_msg_trap
        7       PR_Select
        6       PR_WaitCondVar
        5       -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]
(Reporter)

Comment 1

11 years ago
Created attachment 321613 [details]
Activity Monitor sample for Firefox 3.0 RC1 process
(Reporter)

Comment 2

11 years ago
Created attachment 321614 [details]
 Activity Monitor sample for Firefox 3.0b5 process
Is ForecastFox required to see this problem ?
(Reporter)

Comment 4

11 years ago
If I disable Forecastfox, then the CPU usage seems closer to normal with RC1.

Comment 5

11 years ago
Confirmed.
0%-0.5% with ForecastFox disabled.
10%+ with it enabled.
(Reporter)

Comment 6

11 years ago
OK, I've narrowed this bug down to between the April 7 and April 8 builds.
Perhaps in particular bug 304147
See:
https://bugzilla.mozilla.org/show_bug.cgi?id=304147#c28
Depends on: 432028

Comment 7

11 years ago
Confirmed. ForecastFox need to uninstalled to decrease CPU usage to normal level (comparable to Safari)

Comment 8

11 years ago
This seems to be affecting all Forecastfox installs on FF 3 on Mac OS X. Each window you have open seems to add another 20% or so CPU usage. I used the debugger and it seems to be looping between lines 119-127 on progressmeter.xml ... the _init function in the progressmeter-periodic-redraw binding. I suspect this is bug 432028?

Comment 9

11 years ago
If you run Quartz Debug and turn on "Flash screen updates", you will see ForecastFox icons display flashing repeatedly. This seems to indicate the plugin is updating the display continuously even when there's nothing to update.

I did this test with ForecastFox's display in the Navigation Toolbar. 

Comment 10

11 years ago
What is Quartz Debug? I'll have to check that out. Could it really just be the progress meter bug though? We use an undetermined progress meter, so that may be refreshing in the background. We have no problems with CPU usage on other platforms, making me think its just bug 432028 (which happens to already be listed as blocking this bug).

Comment 11

11 years ago
If you have Xcode installed, it's /Developer/Applications/Performance\ Tools/Quartz\ Debug.app

You can find information about it here: http://developer.apple.com/documentation/Performance/Conceptual/PerformanceOverview/InitialEvaluation/chapter_5_section_3.html

Comment 12

10 years ago
seems bug 442836 is a duplicate.
i have tested and still get this problem in firefox 3.0 and forecastfox 0.9.7.7 (macos 10.5.4)
does not seem to happen on windows XP

user-agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; fr; rv:1.9) Gecko/2008061004 Firefox/3.0
Bug 432028 is marked fixed for Fx 3.0.2. Would anyone care to take this build for a spin:
  http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/3.0.2-candidates/build5/firefox-3.0.2.en-US.mac.dmg
You'll already have this if you're on the beta update channel.

In other news, running Chatzilla on XULRunner 1.9.0.1 is using about 20% CPU on my Macbook Pro; sampling implicates XRE_GetFileFromPath so I'm going to try a nightly build with the fix from bug 432028.
Chatzilla (v0.9.83) lurks around 1% with XULRunner 1.9.0.3pre/2008091108. I expect ForecastFox will be improved too, please test!
(Reporter)

Comment 15

10 years ago
I'm running Firefox 3.0.2 on Mac and this problem seems to be fixed.  CPU usage is around 1% when Firefox is idle.
That's cool, then let's mark this FIXED.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 432028]
Target Milestone: --- → Firefox 3
You need to log in before you can comment on or make changes to this bug.