Search scope selector and search results are not consistent.

RESOLVED FIXED in Firefox 3.5

Status

()

defect
P3
normal
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: dev-null, Assigned: adw)

Tracking

Trunk
Firefox 3.5
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3.5 -
wanted-firefox3.5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 451151])

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9pre) Gecko/2008051906 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9pre) Gecko/2008051906 Minefield/3.0pre

In Library window, when I press Ctrl+F then search, the search scope selector and search results are not consistent.

Reproducible: Always

Steps to Reproduce:
1. Choose Bookmarks -> Organize Bookmarks, then Library window appears.
2. Press Ctrl+F in the Library window.
3. Input search term.

Actual Results:  
All Bookmarks is selected in search scope selector.
But search result seems to be searched in history, not in bookmarks.

Expected Results:  
Search scope selector and search result should be consistent.
this happens with CTRL-F while using the mouse results are consistent, All Bookmarks is selected in the left pane while the real scope appear to be History.

i can confirm this.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

11 years ago
dup of (part of) bug 451151
Blocks: 451151

Updated

11 years ago
Flags: blocking-firefox3.1?
Would be great to get a fix for this, but not holding the 3.1 release for it, wanted+.
Flags: wanted-firefox3.1+
Flags: blocking-firefox3.1?
Flags: blocking-firefox3.1-
Target Milestone: --- → Firefox 3.1
OS: Windows XP → All
Priority: -- → P3
Hardware: x86 → All
Version: unspecified → Trunk
Assignee

Comment 4

10 years ago
This works for me on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6.  Is anyone still having this problem?
reporter was on windows, can we get confirmation on a contemporary windows build?
Reporter

Comment 6

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.2a1pre) Gecko/20090220 Minefield/3.2a1pre still has problem.
Assignee

Comment 7

10 years ago
Thanks for reporting back.

Hmm, yes, this looks like a Mac problem.  The key shortcuts of the OrganizerCommand_find:all and OrganizerCommand_find:current commands are crossed somewhere -- it's impossible to use find:all from my keyboard, only find:current, so when I do Cmd+F from the All Bookmarks folder, it does find:current and looks like it works.  The find:current command in the menubar has its accesskey set to Cmd+F.  When I manually call PlacesSearchBox.findAll(), I can reproduce the problem.  I'm going through the spaghetti of Mac #includes and menubars now.

Dietrich, the fix to this bug looks simple -- we're calling content.applyFilter(filterString) without any folders when PlacesSearchBox.filterCollection == "all".  But part 2 of bug 451151 raises the question of why there's even an "all" case at... all, instead of just using "bookmarks".  findAll() is the only place that sets filterString = "all".
Assignee

Comment 8

10 years ago
To clarify, what should the OrganizerCommand_find:all command do?  What does "all" mean?  Either we need to add an "all" (history + bookmarks) scope button, or change the command so that only one of bookmarks or history is searched.
Assignee

Comment 9

10 years ago
Spun off OS X key issue to bug 479532.
Assignee

Updated

10 years ago
Assignee: nobody → adw
No longer blocks: 451151
Depends on: 451151
Assignee

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 451151]
Target Milestone: Firefox 3.1 → Firefox 3.5
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.