Closed Bug 435268 Opened 15 years ago Closed 15 years ago

Double-clicking an event in the Today pane opens *two* editing windows

Categories

(Calendar :: Lightning Only, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: benjamin.lerner, Assigned: berend.cornelius09)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051906 Minefield/3.0pre
Build Identifier: TB 20080421, Lightning nightly (2008052119)

This is a regression from yesterday's Lightning nightly.  Normally when double-clicking an event in the Today pane, one window opens.  Now, two do instead.  Moreover, the first time the first window that opens is blank -- just a title bar and no content.

Reproducible: Always

Steps to Reproduce:
1. Start TB with today's nightly (2008052119)
2. Double click an event in the Today pane.
3. Two windows appear: the first is empty (like 5px high, with just the title), and the second has the event editor window.
3. Close both windows that pop up.
4. Double click the event in the Today pane again.
5. Two windows appear: both have the event editor window in them.
6. Double click an event in the Day, Week, Multiweek or Month view.
7. Only one window opens.
Assignee: nobody → Berend.Cornelius
Attached patch patch v. #1 (obsolete) — Splinter Review
regression to bug 433937. That patch lead to the situation that both the agendalistbox and the selected richlistitem responded to the click-handler.
I modified the behaviour in such a way that now the listbox only reacts to doubleclicks when no richlistitem has been selected.
I am asking Daniel for review because Philipp is busy with his examination. But if Philipp has some spare time he could of course also take over the review.
Attachment #322248 - Flags: review?(daniel.boelzle)
As I reported in bug 433937, that bug also seems to have broken right clicking (there is no context menu).  IMO that bug should simply be re-opened until it's fixed properly instead of creating a bunch of new bugs.
Pete, my context menu works fine. Which platform?
I'm using WinXP sp3 ("Classic theme"), Lightning 0.9pre 2008-05-21 19 / Thunderbird 2.0.0.14.  No errors in the Error Console.  I'll try it with a clean profile.  Thanks.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Status: NEW → ASSIGNED
Attached patch patch v. #2Splinter Review
I currently don't have a Windows environment, but this patch should fix the context problem. Pete, if you feel inclined you may test if it still occurs.
Attachment #322248 - Attachment is obsolete: true
Attachment #322260 - Flags: review?(daniel.boelzle)
Attachment #322248 - Flags: review?(daniel.boelzle)
Blocks: 433937
Keywords: regression
I manually applied each change in this patch (v2) to my Lightning .xpi file (not easy!).   I'm happy to say that this patch seems to fix this bug (double clicking no longer opens two dialogs) and also the other thing (context menu now works again in XP).  So thanks, Berend!

I did notice one minor problem:  if I right click on event A, the context menu opens, then I double click on event B, the event dialog opens for event A instead of event B.  It's possible that this behavior has always existed in Lightning and it seems that people won't experience the problem very often.  This is just an FYI.  If it bothers me enough I'll create a new bug for it one day.
Comment on attachment 322260 [details] [diff] [review]
patch v. #2

>+            if ((event.detail) == 1) {
why the extra pair of parenthesis?

anyway r=dbo
Attachment #322260 - Flags: review?(daniel.boelzle) → review+
patch checked in on trunk and MOZILLA_1_8_BRANCH

->FIXED
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Thank you Pete for your assistance. Again I could not reproduce your scenario described in comment #6 on Linux.
Target Milestone: --- → 0.9
This checkin most probably regressed Bug 436333.
Checked in lightning 2008061918 -> Verified.

It is also possible to reproduce the minor problem described in comment #6 -> bug 440693
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.