Closed Bug 435485 Opened 12 years ago Closed 2 years ago

Cannot reliably use the "Move" command in Places (left pane)

Categories

(Firefox :: Bookmarks & History, defect)

3.0 Branch
PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jbecerra, Unassigned)

Details

Fx3rc1, Mac OS X 10.4.11, litmus test case 5142. In the bookmarks library you can select an RSS feed in the left pane and you can click on the Organize tool to move the rss feed to a different folder. But the move doesn't take place. Selecting the rss feed when in the right pane and moving it works.

Steps:
1. Open the bookmarks library
2. Navigate to the Latest Headlines default rss feed in the left pane
3. Click on the Organize tool drop-down button and select to move.
4. Select some folder to move the feed to and OK

Expected: Rss feed should be moved to the new location.

Actual: Nothing happens.

If we are not supposed to move items when selecting them in the left side pane, let's not enable the organize tool.
Summary: organize tool should be disabled when selecting left pan in bookmarks library → organize tool should be disabled when selecting left pane in bookmarks library
Hasham and I have both seen this bug on Tiger using the latest RC candidate. I have seen it as well on Leopard using  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008053008 Firefox/3.0 with a new profile.

The only way I have been able to move an existing folder or a new one I have created is to drag and drop it. Using the "Move" command does not work for me. There are no errors in the Error console after the failed move operation.
I also tested this on the latest nightly on Windows XP and the Move command works fine. 

The other thing to note is that Tomcat has not been able to reproduce this on his machine using Leopard.

Here are my exact STR:

1. Using a new profile, create a new folder on your bookmarks Toolbar.
2. Go to organize bookmarks and highlight that new folder. 
3. Use the "Move" command from the Organize Bookmarks menu to move the Folder to the Bookmarks Menu.

Expected: It would move.
Actual: It does not move using the command.

Summary: organize tool should be disabled when selecting left pane in bookmarks library → Cannot reliably use the "Move" command in Places
I just wanted to clarify that in comment 1 that I am choosing the folder from the right hand side of the Organize Bookmarks pane.
Marcia, are you able to "Move" when the folder is selected in the right (View) pane?  If so, the previous summary was accurate. Move of a folder in the right pane is WFM. However, move when selecting a folder in the left pane is broken.  
Tracy: Sorry, my previous comment was incorrect. I meant I was selecting from the left pane, not right pane. I had hoped Tomcat would comment in the bug since he was not seeing it.
Summary: Cannot reliably use the "Move" command in Places → Cannot reliably use the "Move" command in Places (left pane)
I repro'd this also using STR in comment 0 on 10.5.  It however, WFM on windows and linux rc2 builds.  Seems to be mac-specific only.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
The move dialog has been removed in bug 1432112 in FF 60, hence this bug is not needed any more.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.