Closed Bug 435588 Opened 14 years ago Closed 14 years ago

EULA shouldn't be shown on builds other than mozilla.org ones

Categories

(Firefox :: General, defect)

3.0 Branch
x86
Linux
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 443918

People

(Reporter: glandium, Unassigned)

Details

Everything is in the summary.

What would you think of setting browser.EULA.override to true in firefox.js, depending (#ifdef) on MOZILLA_OFFICIAL or BUILD_OFFICIAL ?
It seems to be a serious bug, that transform open source builds into proprietary ones. This must be fixed.

At first I thought it was a packaging problem in the distribution I use (ArchLinux) but in fact it seems it is Mozilla Web Browser's fault (I don't know which name to use, should I use Minefield that is a temporary name or Firefox that doesn't fit for open source binaries ?). well, that's not quite true because if you know where to change the preferences to remove the EULA, you can have an open source browser.
There are a certain number of things we'd have to disable for all but official builds if we did this, including safe browsing at the least, but possibly more.  We're looking at understanding our options here, but the EULA provisions are tied to services the app uses, not just the browser itself.

This bug is invalid, however. Official or not, the EULA covers services that exist in other code, and we're looking at how to minimize the things that require a EULA, and its possible that once that list is crisp, we could have some sort of EULA-free build switch (which would not build any code that accesses services that require a EULA).
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
(In reply to comment #2)
> This bug is invalid, however. Official or not, the EULA covers services that
> exist in other code, and we're looking at how to minimize the things that
> require a EULA, and its possible that once that list is crisp, we could have
> some sort of EULA-free build switch (which would not build any code that
> accesses services that require a EULA).

The first paragraph of the EULA is highly confusing in that case.

It says:

        A SOURCE CODE VERSION OF CERTAIN FIREFOX BROWSER FUNCTIONALITY THAT YOU
        MAY USE, MODIFY AND DISTRIBUTE IS AVAILABLE TO YOU FREE-OF-CHARGE FROM
        WWW.MOZILLA.ORG UNDER THE MOZILLA PUBLIC LICENSE and other open source
        software licenses.

To me, that suggests that there's source that's available under MPL, (not MPL
+ EULA), but I can't find any such source.

The phrasing of "other open source software licenses" is interesting as well.
Obviously, one of the "other" licenses is the GPL which prohibits use
restrictions. Yet the EULA does nothing but impose use restrictions.

I don't see how "Nothing in this Agreement will be construed to limit any rights granted under the Open Source Licenses" can be squared with the GPL's
language that "The act of running the Program is not restricted". Or rather,
the only way I see of squaring those two is that the EULA has zero effect
and should not require acceptance before allowing the application to run.

Quite confused,

-Carl


Since the source code is under open source licenses, i don't see how it could be possible to force the user who built mozilla from source to accept a non-free license. That's why I disabled the EULA and I think I have complete rights to do it.

Or is Mozilla is no longer free, just state it clearly instead of showing a non-free license at run time. So it could be possible to fork from a previous open source version of Mozilla (I can't say Firefox since Firefox was never an open source software)
See Bug 439604 (and Bug 443918 which is a duplicate).

This bug is invalid because the EULA is necessary since Firefox/Minefield is using services that requires it. But it could be possible to decline the EULA and have Firefox/Minefield without these features. But it would still be free software.
Please, No EULA. keep the good work Mozilla.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 443918
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.