Closed Bug 439604 Opened 11 years ago Closed 11 years ago

Firefox 3.0 requires agreement of non-Free EULA

Categories

(Firefox :: General, defect, major)

3.0 Branch
x86
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 439858

People

(Reporter: steve, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008052912 Firefox/3.0

When first started, FireFox 3.0 requires the user to agree to a non-Free EULA in order to use the software.  Leaving aside the fact that click-through EULAs are unenforceable (since it is impossible to prove that the user agreed to it), the parts of the EULA which restrict the software itself should be removed from non-mozilla.org builds.  Additionally, the user should be allowed to decline the parts of the EULA governing off-site services, such as safe browsing, and thus have those features disabled.

Reproducible: Always

Steps to Reproduce:
1. Start fresh FireFox 3.0 install

Actual Results:  
User is required to agree to an EULA in order to use the software

Expected Results:  
The EULA should be removed entirely, or the user should have the option of declining the EULA and thus disabling just the features that agreement to the EULA restricts.
>the parts of the EULA which restrict the software itself should be removed from
>non-mozilla.org builds

See bug 435588 for this bit.
Bug 435588 states that the EULA is needed for:

1. "services that exist in other code" - it is unclear what this means, but I presume this code is not in the Free source code, so this part would not apply to unofficial builds.
2. "services the app uses" (e.g. safe browsing) - the user should *always* be given an option to decline this part of the EULA and opt out of using these services.

Bug 435588 also suggests that there could be a "EULA free" build switch (which is essentially what that ticket was asking for), and yet the bug has been marked as invalid rather than being fixed.

It is important to realise that, whilst the EULA apparently does not apply to the browser itself, it is impossible for one to use the browser itself without either agreeing to the EULA or hacking it out of the software.  This pretty much goes completely against the ethics of Free software and serves absolutely no purpose other than to exclude legitimate users.
I'm pretty sure that this will be closed as a WONTFIX. The official binary distributions *are* non-free because they contain branding protected by trademarks. There's no evil intent here, as has been stated more or less in the trademark policies, Mozilla just doesn't want people to ruin their good name with modified builds that don't meet their quality standards.
See http://en.wikipedia.org/wiki/Mozilla_software_rebranding for some alternatives - you can easily get a rebranded or unbranded browser if this concerns you, or build from sources, which ARE free software / open source under FSF and OSI definitions.
(In reply to comment #3)
> The official binary
> distributions *are* non-free because they contain branding protected by
> trademarks.

Incorrect. See: http://www.mozilla.org/foundation/trademarks/faq.html
Even if this were the case, protecting trademarks is something that concerns distribution, not end users - an end user licence agreement doesn't concern distribution.

Also, as already mentioned, EULAs are totally unenforceable since you can never prove that someone agreed to it - they only serve to discourage people from using the software.
See also 443918, which also has code references for a fix.
Bug 443918 (sorry)
I don't see how it could be possible to enforce EULA agreement on open source software (that is, Minefield). Because you can change the source code, you can remove the EULA without having to accept it.
That's exactly what I've done to have an open source Minefield.

So, why not removing it completely on open source builds ?
I suspect that most people who build open source Minefields just disable it already.
> I don't see how it could be possible to enforce EULA agreement on open source
> software (that is, Minefield). Because you can change the source code, you can
> remove the EULA without having to accept it.

It doesn't matter whether it is  open source or not - you can remove the EULA from binaries.  Having the source code just makes it a bit more trivial.  Also, since the EULA doesn't record the signature (or other authentication credentials) of the person accepting it, you can never prove that a specific person ever agreed to it.
Product: Firefox → Toolkit
This is causing a lot of heat in Ubuntu bug tracker : https://bugs.launchpad.net/firefox/+bug/269656 

It seems people would rather using another browser (or an unbranded Firefox) than being nagged with EULAs. 

This surely won't help brand recognition.
> It seems people would rather using another browser (or an unbranded Firefox)
> than being nagged with EULAs. 

> This surely won't help brand recognition.

Precisely.  Debian found Mozilla's trademark requirements too onerous, and opted out.  Ubuntu may well follow, and if other non-commercial distros jump on, it could become very common that Linux comes with unbranded FF.

I can't see how this serves to strengthen the brand.
"This surely won't help brand recognition."

I agree. Ubuntu's brand will suffer if disassociated from Firefox as is proposed here and in the Ubuntu bug.
asa: This bug isn't Ubuntu, or even Linux-build specific.

Firefox has reputation, one of those brand elements is a popup-free browsing experience.

Worthless EULAs are still popups that get in the way of browsing, even if they only show up once.
My understanding is that you require this EULA in order to protect the Firefox brand, but don't you see that in reality you are surely destroying it?  It won't be long before Firefox is no longer used by any Linux distributions, netbook laptops, etc.  Is this what you really want?  We all want Firefox to succeed, I just hope you find another way to protect the brand without an EULA, for the sake of Firefox itself.
(In reply to comment #12)
> "This surely won't help brand recognition."
> 
> I agree. Ubuntu's brand will suffer if disassociated from Firefox as is
> proposed here and in the Ubuntu bug.

You're right - it will hurt both Ubuntu and Firefox alike.  But it will also hurt Ubuntu if they allow EULAs in such a core program, and a program that is in the default install.
I really hope Mozilla backs down on this.
Please Mozilla, don't do that. we love your browser because it's free (as in freedom).
Summary: FireFox 3.0 requires agreement of non-Free EULA → Firefox 3.0 requires agreement of non-Free EULA
It's pretty clear that Mozilla has made a minor error of judgment, perhaps pushed by legal counsel that wanted an EULA in a knee-jerk reaction to "OMG we don't have one???"

As others have noted, the EULA does nothing to protect distribution or trademark.

Mozilla -- it's time for you to take the high road, admit that you've made a mistake, remove the EULA requirement, and go on doing what you do best -- making the world's best browser.

It would be disappointing to see all your effort go to furthering unbranded versions, and THAT IS WHAT WILL HAPPEN.  

Those who do not learn from history are doomed to repeat it -- George Santayana

Hopefully you will learn from your Debian history and take this opportunity to correct your error.

Respectfully

Ehud Gavron
Tucson AZ
Component: Startup and Profile System → General
Product: Toolkit → Firefox
QA Contact: startup → general
Version: unspecified → 3.0 Branch
This question is one of policy, and as an End User (subject to EULA), may I suggest that you split up the core elements and licensed additions and present the user with the licence as the first-run browser start page which features two buttons: "Have the extras and agree to the licence" and "Have no extras and avoid a licence".  This should concede to the third-parties who require additional licensing.  If Mozilla (MoFo or MoCo) require the licence, please re-examine the policy that made that decision.

K3n.
Distro's that opt out should also remove google as the default search tool.

Mozilla foundation may think again if the opting-out distro's take the google referral money with them.

Sam
Sam, I would suspect that simply rebranding it would mean that Mozilla does not get google's referral money.  No need to remove the google search tool.
Thanks John;good point.

But it may make google lean on Mozilla, or make Mozilla fear that google will abandon the deal; after all why keep it going if Mozilla wastes all the goodwill?

And the aim is to get the Mozilla guy to change his mind... so the distro's need to get the knives out - or rather their users do...

Then maybe Mozilla will quickly cut off the bit that is causing offense instead of getting cut off themselves.

Thankfully free-software can survive change-of-regime even if the organization can't.
Haha, I see your point - but I think that's more petty than anyone wants to go
:-)
(In reply to comment #21)
> But it may make google lean on Mozilla, or make Mozilla fear that google will
> abandon the deal; after all why keep it going if Mozilla wastes all the
> goodwill?

First, you have a fundamental misunderstanding of the financial relationship between Mozilla and Google. Second, if you were paying closer attention you'd know that we don't optimize for revenue and never have. 

Empty, misinformed, and petty threats don't belong in our bug reporting system. Take them to a blog or over to Ubuntu's bug system where uninformed rants seem to be happily accepted.
Asa, getting hostile to Ubuntu users and developers is really not answer here.  If you are able to clarify and inform the rants on the Ubuntu bug system, then please do.  There are a lot of questions still to be answered.
(In reply to comment #12)
> "This surely won't help brand recognition."
> 
> I agree. Ubuntu's brand will suffer if disassociated from Firefox as is
> proposed here and in the Ubuntu bug.

You are quite wrong if you think this is an Ubuntu vs Firefox problem.

Quite honestly, I've been expecting the s* to hit the fan Fedora-side as soon as the EULA was merged in rawhide. You're only seeing Ubuntu users now because Ubuntu is the first to have widely distributed this particular mistake.
Asa, many Ubuntu and other Linux distro users are among the most vocal advocates for the Firefox web browser, not to mention active contributors in terms of bug reporting etc. Taking a cheap shot at the excellent Launchpad doesn't really help address user's genuine concerns about this EULA.
Sam@19: Remember that the officially blessed win32 shipments far out number the officially blessed Linux.* shipments; the amount of impact a distro (even a large one) does by "taking the search-engine referral revenue elsewhere" is not enormous.  That extra money is probably better spent on upstream Mozilla development.

But... also remember that it's not just officially blessed Linux users who are getting the EULA.  Everyone is getting a EULA.  The difference is that the EULA nag screen is much more obvious---on MS Windows it's just-another-OK-box-to-click (there are dozens).  On a Linux distribution, it is the *only* nag/EULA screen.  (Fedora removed their distro EULA, Ubuntu never had one).

Ken@18: that is the most constructive suggestion I've seen so far;  (optionally turn /on/ the semi-proprietary extras vs. turning everything off or) and in a way that does not create a modal hold-up.

Asa@23: remember that for every action there is an equal and opposite reaction.  If a particular distro's brand/popularity suffers; so does Mozilla's---because users' who-would-just-prefer-to-use-the-software likely get frustrated.

Generally:
In the situation that lead to this bug report; it's problematic.  A proportion of users are going to get upset if $distro ships with one nag screen more than previously. A proportion are going to get upset if $distro ships looks-like, smells-like, but-isn't-quite Firefox because they really miss the cutsy icon and can't show it off to all their friends.

The people who I really feel for are the IT/support people; instructions that worked for the last three years now no longer match up and each machine needs visiting individually after installation to click-through the EULA on behalf of the (unknown unknowing) user who will eventually use that new machine (MS Windows, Mac, or Linux).  Some users get (initially) upset when IE is replaced with FF; now they have to click something extra in addition?

Live CD, cybercafe, network-machines---and anything without state-saving---is going to show the EULA more than once.  (Getting "Okay, gimme me my IE back" reactions is frustrating for somebody (I) who pushes Firefox when there is a chance.
I'm very sad to see things like this happening. At the beginning, Linux, to be more precise, open source community was biggest Mozilla supporter. I don't think is too arrogant to say that there wouldn't be Mozilla Corp if there wasn't Linux community. Linux community wasn't so vocal when Firefox became almost unusable on Linux. It's a fact that Firefox now is no where near what it used to be on Linux platform. But we were OK with that...

As for Ubuntu community, Mozilla should be aware that some local Ubuntu communities did most/all of the work on some Firefox localizations, including man power and financing localization projects. Mozilla should also be aware that localizing Firefox over Launchpad is *a lot* easier than with Mozilla tools. Ubuntu community/Canonical even made possible to convert gettext to Mozilla's translation format.

Don't make your most vocal supporters your most vocal enemies. I like Firefox and I was its biggest supporter from the beginning, making it browser #1 everywhere I worked, introduced hundreds of people to it. I think that those latest moves will only hurt Firefox and Mozilla, which is too bad.
An EULA has NO place in Free Software. 

It probably conflicts with the GPL codebase.

Not being a US Citizen, and having no desire to become one, I am not in a position to accept or even understand US export restrictions.

The way Ubuntu have distributed FF3.0.2 in Ibex means that simply by reading the EULA (You get a new tab in FF) I have automatically, and without my consent, accepted the conditions of the EULA. Someone will have a field day with that one...

Get real, and drop it Mozilla.
IIRC it was 3.0a4 that i first saw this in so its not new to 3.0.*
Please Mozilla, hold your lawyers ...
No obtrusive EULA pleaze
Thanks, Mozilla guys.

You've just made me anxious to try another browser.
Maybe it's time to move on, after um... several years (I can't remember when
FF-0.6 was published, but I started using it then).

Good night and [don't?] let the nightmares get you.
This situation is being worked on, see Mitchell's blog post at http://blog.lizardwrangler.com/2008/09/15/ubuntu-firefox-and-license-issues/ .

Please refrain from posting emotional comments like #31 and #32 (see Bugzilla Etiquette https://bugzilla.mozilla.org/page.cgi?id=etiquette.html), posting them does not help fixing this issue in any way. (Posting constructive propositions - does).

Let's keep this bug page clean and get this problem fixed so that both sides are happy. :)
aza said:
"I agree. Ubuntu's brand will suffer if disassociated from Firefox as is
proposed here and in the Ubuntu bug."

Respectfully you've got it upside down:
in this story Mozilla IS XFree making a tantrum, not Ubuntu or others reacting to it. and the resulting Xorg (probably in the form of IceWeasel) will hurt the Firefox brand, not the other way around.
> Please refrain from posting emotional comments

Yes, I apologize for that. It was in the line of "somebody hear me, please!"
For my part I am after unobtrusive solution like this one:

http://fedoraproject.org/static/firefox/
In answer to comment #34 :

I have to disagree. Here is what I said on ubuntu launchpad related bug :

https://bugs.edge.launchpad.net/ubuntu/+source/firefox-3.0/+bug/269656

"

Besides doing bad things on fly (as we say in France), this problem is half fixed :

https://bugzilla.mozilla.org/show_bug.cgi?id=443918

"Open-Source CVS version of FF forces me to accept proprietary, non-Open-Source EULA (license)"

It is closed as fixed, and as far as I can see, it is on both trunk and 3.0 branch.

For me, not using firefox branding is a mistake. Because average joe user who used firefox on Windows will be lost for not seeing it on Ubuntu.

Just my guess, of course.

Feel free to flame me if you disagree."
As Wiktor mentions the fedora solution:
http://fedoraproject.org/static/firefox/

I say that this solution is nearly fine.

Instead of saying "if you don't agree, click here, there, and everywhere to prove it" it should say "if you do agree, click HERE" and safe-surf default to off.

If mozilla don't want safe-surf defauting to off, then it should defalt to "warning: you haven't made up your mind" mode, giving them a yes/no box were yes shows the service agreement again.
while it might not be productive to post emotianal comments, i think there still is lack of understanding what caused this problem. from my viewpoint (which is only confirmed in comments here), it is arrogance.
i've heard that mozilla developers do not care about linux, that windows-specific solutions are proposed as completely satisfying. but annoying your users isn't smart for any software project, especially opensource one.

the question mozilla corp should ask themselves - how could this ever come so far ? why was it allowed to creep in, why all the rude resistance to get this anti-opensource clause changed ?

yep, i doubt anybody will claim this is a normal opensource software situation - firefox package fails clause 3 from http://www.opensource.org/docs/osd : The license must allow modifications and derived works, and must allow them to be distributed under the same terms as the license of the original software.

as noted before, do not make your most vocal supporters (even if zealot a bit) your opponents. **** on users from a high tower can hit a power line.

while i doubt an xfree-like demise in near future, this case surely has not helped the mozilla corp image in anyway. myself, not being everyday firefox user, i was advocating it. now i will examine other options more closely.
> each machine needs visiting individually after installation to
> click-through the EULA on behalf of the (unknown unknowing) user
> who will eventually use that new machine

This point shouldn't be underestimated.  In situations where users are installing software at work, they are usually not in a position to accept random contracts on behalf of their employer.  I guess for most Windows users they just click through EULAs anyway (with potentially serious consequences if it turns out the EULA contained some particularly nasty terms).  But employees of most companies *should* be getting their legal departments to look over contracts before agreeing to them, and I can't see many employers wanting to expend the time to get lawyers to look over the EULA for a web browser.  This may mean that FireFox can't be used in many offices.
> i've heard that mozilla developers do not care about linux

I just want to make clear that Asa does not speak for the Mozilla community.
Many in the Mozilla community (outside and inside of Mozilla Corporation) use Linux and/or care deeply about it and open-source in general.
(In reply to comment #40)
> > i've heard that mozilla developers do not care about linux
> 
> I just want to make clear that Asa does not speak for the Mozilla community.
> Many in the Mozilla community (outside and inside of Mozilla Corporation) use
> Linux and/or care deeply about it and open-source in general.

Likewise from the Ubuntu community.
This EULA is useless because it just states things that are handled by MPL, copyright law, and trademark law.
There's a good analysis of it here: http://spot.livejournal.com/299409.html
(fragment:)
"While this new EULA is far superior to what we originally got with Firefox 3, it is still a EULA, and in my opinion, still really doesn't serve a useful purpose. The MPL works really well as a binary and source license (I'm not going to debate its merits vs other licenses), and it is widely adopted and used in many communities outside of Firefox. This EULA serves to undercut that, and says that Mozilla doesn't have confidence in the terms of the MPL. I'm sure that this isn't what Mozilla intends, but it is certainly what they achieve.

If you look at the revised EULA, it boils down to a few key points:

1. It states that the Firefox binaries and source are available under the MPL.
2. It states that you do not get special rights to the Firefox trademarks above what is normally permitted by law.
3. It states that the Firefox binaries are subject to US export control laws.
4. If you don't follow the terms of the license, you no longer get the rights to use Firefox under this license, which is how copyright law works in the US.
5. It tells you where the Mozilla Privacy Policy is.
6. It tells you about the additional terms for their Website Information Services (what we now cover at http://fedoraproject.org/static/firefox/).
7. It disclaims warranty (which the MPL already does)
8. It limits liability (which the MPL already does)
9. It defines the product with US Government terminology (which the MPL already does).
10. Some extra legalese about the EULA, that it is an agreement, governed in the state of California (and not by the UN), and if any part is determined to be unenforcable, the rest still holds. Oh yes, it's only valid in English. Basically, this is legal boilerplate.

Now, on these points:

1. Covered by the MPL
2. Covered by Trademark law (you don't need to state it to make it true)
3. Covered by US Export Control laws (you don't need to state it to make it true)
4. Covered by US Copyright laws (you don't need to state it to make it true), the MPL also covers this.
5. Okay, good to know.
6. Okay, good to know.
7. Covered by the MPL
8. Covered by the MPL
9. Covered by the MPL
10. 95% of this boilerplate is ... wait for it... covered by the MPL

To sum it up: The EULA isn't really necessary, aside from points five and six, which while relevant for users of Mozilla's web services, has ZERO to do with the terms for use of Firefox. In fact, the way that Fedora is handling it now, clearly covers point 6, and could easily be amended to cover point 5, then the need for the EULA falls away entirely."
This is much more important than some people realize.

When I migrated from Windows to Ubuntu I was amazed and delighted with the feeling of warm welcome. I can't be the only one.

People had prepared, for me and others, this carefully composed system, and there were these impressively huge repositories were I was welcome any time I wanted to add something to my new system. It was a truly astonishing feeling of generous caring and welcoming.

If there had been an EULA with its typical "you agree to be bound by these terms" and "if you do not agree...uninstall...", this would have shattered the feeling of warm and generous welcome.

If Firefox requires an EULA, then the firewall has much stronger reasons than Firefox, because it will block some of my communications, and also because it can't protect me against everything; or else the lack of a firewall has even stronger reasons, due to the lack of protection; and then every editor requires a EULA, because it can destroy my texts and my website; and rm needs an EULA, because it can destroy all my files; and fsck needs one, since it can't repair everything; and the shell's ">" needs one; and the filesystem; and the kernel...

You could spend an hour just clicking away EULAs. You'd spend many days if you tried to read them.

But even if there's just a single "you agree to be bound", that's enough to seriously mar that first impression. You would no longer get that delightful feeling of warm welcome.

The amazing first impression has left me charmed and hooked. I can't be the only one. Don't sacrifice that.
Imho Mozilla making a huge mistake here. Now opensource people will be unhappy and will dislike Mozilla, Firefox and it's products strongly and for some real reason - you're (not "we are" anymore, sorry) valuing some bunch of crazy lawyers much more than users who really allowed Mozilla to became this popular by advertising it, making it better, etc.

The beast has grown. And now it finally big and powerful. Sadly it appears that it now treats its users just as kind of tasty food. 

I did some bugs reporting here. Maybe not perfect and not too much. But absolutely free anyway. As well as reported zillion of broken sites, surely some advertising and so. For what? Just to get such insult and annoyance instead of "thanks"? Surely, it is not what I wanted as a reward for my efforts. Now Mozilla proved that bunch of mad lawyers more important for them than their users, their response and their convenience. I always valued Mozilla for freedom and innovations. Now it going to change? I do not value this boring proprietary-fashioned licensing ****. I even hate word "EULA", to let you know. Probably not only I am, if we'll look around. I will no longer advertise Firefox to users. Because long term goals of Mozilla are now looking too questionable for me.

Strangely, Mozilla was not sued so far. But for whatever reasons needs to screw anyone up anyway. Surely that's up to them. But this will be potentially very harmful. For Mozilla itself. Their choice though. I have to accept it and live with it. But this may lead to using another browser which does not insults me with wrong EULAs and other moron **** from mad lawyers.

As a last words (it may happen that this will be my "good bye" words in this bugtracker) I can give a hint as professional tester and UI-related guy: if "you" (not "we") still SO need to display your f...ng EULA ****, you can open page of inside the browser, after all. Like some addons do. Slightly less annoying. And avoid word "EULA" in Linux and anywhere nearly to opensource guys. "License" or "license agreement" or whatever is slightly better than "EULA" which is probably one of most hated words in whole opensource world. So if you want to get hated by opensource people, bothering people with "EULA" is very effective way to achieve this. Proven by you already.
t3st3r@44: Think positive here;  Mozilla may have (past tense) made a mistake.

But mistake is being worked upon;  in fact here are the fresh screenshot mock-ups of the latest start-page:

  http://lockshot.wordpress.com/2008/09/17/licensing-proposal/

Which I'm sure would benefit from positive/constructive suggestions and feedback.
These screenshots look *excellent*.  Mozilla really stepped up to this, admitted they were wrong and are fixing the problem.  Bravo!  I am sure that working with the community to fix this issue will even further solidify your position as the dominant open source browser.  Now if only we could find a way to get you back into Debian. ;)
Very nice - a step in right direction.
This looks very good to me.

Just as a curiosity, but do the legal guys think it is ok having the "web services" agreement as something you don't have to explicitly agree to?  I'm of the firm belief that a click-through licence is unenforceable, but an agreement you don't even have to agree to sounds even less enforceable.  (I'm certainly not trying to discourage it from being done this way - from the end user perspective it's great, I'm just interested in how useful the legal guys think it is from the Mozilla's perspective)
"but an agreement you don't even have to agree to sounds even less enforceable [...] I'm just interested in how useful ..."

actually, this is worst: someone ( say, who lost data by using mozilla web services ) could sue for *intentionally* not presenting him a *clear* and *visible* agreement ( i mean, with an Agree | Not Agree button ).
What about someone who lost data because the Linux kernel crashed?
Could they sue Linus for that?  Should be thus have a EULA when you
boot up that prevents booting unless you agree?
 Disable web service by default.
 Add Big warning about the danger some one might get from phishing and but a button to enable anti-phishing.
Paul Sladen@45:   
> Think positive here
Uhm, we'll see. Time will show. Looks like Mozilla got idea that there is not everyone happy with their doubtful actions - that's great, then.

But anyway: several years ago I was not even able to imagine such moron situation and that so many words will be spent about such useless and annoying topic. IMHO Mozilla should keep their lawyers aggression and paranoia at reasonable levels instead of threatening others.

Ryan Hayle@46:
> Now if only we could find a way to get you back into Debian.
Debian guys are paranoids but this leads to better protection of their users. 

Nobody able to cause for example such "EULA threat" to Debian and it's users. 
Hence, Debian proved to be stable and predictable once more - that's one of main Debian properties valued by certain users and companies who prefer to make their developments using Debian as their base. Others however have learned some not very easy lesson that sometimes Debian paranoia in picking software with "proper" licensing and their attempts to retain as much independence as possible is not-so-unreasonable as it may look.

So I doubt Debian will use usual Firefox, ever. And that's for good reason, at least sometimes. At lest, Debian users do not suffer from any trademark threats, possible trademark policy changes, they do not have to approve their patches by Mozilla and they do not have to click EULAs. This clearly looks like their advantage over others.
Consolidating bugs.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 439858
You need to log in before you can comment on or make changes to this bug.