Give the window on error messages.

RESOLVED DUPLICATE of bug 228205

Status

Toolkit Graveyard
Error Console
RESOLVED DUPLICATE of bug 228205
10 years ago
2 years ago

People

(Reporter: John J. Barton, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows XP

Details

(Reporter)

Description

10 years ago
nsiConsoleListener gets error messages from all windows mixed up. This didn't matter much before AJAX etc. But now tools like firebug can't always figure out which window the errors belong to.  Messages like:

@mozilla.org/scripterror;1 

give a URL, but it will be incorrect for eval, event, and xbl pages, and users can have more than one window open on a URL anyway.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 228205
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.