Weave should allow to select/de-select individual Bookmarks-/Places (incl. Folders) for syncing

RESOLVED WONTFIX

Status

Cloud Services
Firefox Sync: Backend
--
enhancement
RESOLVED WONTFIX
10 years ago
5 years ago

People

(Reporter: Peter Lairo, Unassigned)

Tracking

unspecified
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

Weave should allow to select/de-select individual bookmak/Places folders for syncing

This should include individual bookmark folders as well as top-level folders (e.g., the "Bookmarks Toolbar".

Reason:
There are bookmark folders i use at work that i don't want to see at home and vice versa.

Reproducible: Always



Expected Results:  
By default, all bookmarks and bookmark folders should be selected for syncing.

Right-click on a bookmark folder and select "exclude from Weave synchronisation" (or, if previously excluded: "include in Weave synchronisation".
(Reporter)

Comment 1

10 years ago
... or provide a UI similar to the "Edit this bookmark" dialog with a bookmark folder tree where the user can add and remove checkmarks next to the bookmarks and bookmark folders. (please make this dialog large (tall) enough to avoid excessive scrolling)
Summary: Weave should allow to select/de-select individual bookmak/Places folders for syncing → Weave should allow to select/de-select individual Bookmark-/Places-Folders for syncing

Comment 2

10 years ago
Targeting this for 0.3 for now.
Target Milestone: -- → 0.3

Comment 3

9 years ago
These bugs need to be triaged, removing 0.3 milestone setting.
Target Milestone: 0.3 → Future
(Reporter)

Updated

9 years ago
Summary: Weave should allow to select/de-select individual Bookmark-/Places-Folders for syncing → Weave should allow to select/de-select individual Bookmarks-/Places-Folders for syncing
(Reporter)

Updated

9 years ago
Summary: Weave should allow to select/de-select individual Bookmarks-/Places-Folders for syncing → Weave should allow to select/de-select individual Bookmarks-/Places (incl. Folders) for syncing
(Reporter)

Comment 4

9 years ago
The settings should be remembered on a per-PC basis. So the bookmarks I (de)selected at work are not the same as the bookmarks I (de)selected at home.

The UI would be similar to most typical backup programs.

[ ] Folder 1
    [ ] Bookmark 1
    [ ] Bookmark 2
[X] Folder 2
    [X] Bookmark 3
    [X] Bookmark 4
[/] Folder 3             <-- partial selection!
    [ ] Bookmark 5
    [X] Bookmark 6

Selecting a folder selects all its contained bookmarks.

De-selecting a folder de-selects all its contained bookmarks.

PS. This bug is pretty important for me. It is preventing me from testing/using Weave (don't want to share *all* my Home and Work bookmarks).
I would use this to exclude the Bookmarks Toolbar.  The toolbar is on by default and people are encouraged to put links they want to access quickly/often in the toolbar.

However, the links I want to access quickly and often are completely different depending on what computer I want to use so when they all merged it broke my work flow.

Comment 6

9 years ago
It's a reason why one hardcoded "personal toolbar" folder is bad.
Old mozilla behaviourwas more comfortable - when user can assign any folder as "toolbar". Including root folder.

Comment 7

9 years ago
Certainly it'd be nice to see something done here.  I'd like some input from the UX team, though, my initial reaction to the UI proposed in comment #4 that it would be clunky.  I'd like something that feels like it's a part of Firefox.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #6)
> It's a reason why one hardcoded "personal toolbar" folder is bad.
> Old mozilla behaviourwas more comfortable - when user can assign any folder as
> "toolbar". Including root folder.

I'll admit the first thing I tried after the merge was to create another toolbar only to discover I couldn't drag bookmarks onto it.  I agree the old behavior was a better solution than ignoring the folders but that's a different bug I suppose.

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
QA Contact: weave → general
(Reporter)

Comment 9

9 years ago
Perhaps to make this important goal more achievable, it would already be a huge improvement if the user could just select *folders* (and not individual bookmarks) for synchronization.

[ ] Folder 1
    [ ] Folder 1.1
    [ ] Folder 1.2
[X] Folder 2
    [X] Folder 2.1
    [X] Folder 2.2
[/] Folder 3             <-- partial selection!
    [ ] Folder 3.1
    [X] Folder 3.2

Comment 10

9 years ago
It would be great to have a feature like Xmarks, where you can create "Sync profiles"

If i take the previous example, you can access the whole sync datas on a webpage, and select which folder/bookmark belongs to each profile.

Then when you install weave on a new computer/device, you choose which profile shoud be imported.

Comment 11

9 years ago
One step back, in terms of syncing, we would always want to sync to the server so that you can always retrieve the bookmark. Even if you don't want to share it to another machine, the current machine could make use of that server record. And if you ever end up having two "work" machines, you can sync that way.

From weave discussion group:

Gary Gendel: How about using tags that can identify groups that you don't want to sync?

Weave could decrypt bookmarks and look for tags/annotations and decide to not add the bookmark to the local computer. Not sure yet how it'll interact with other clients if one says it's done syncing but didn't actually sync everything (on purpose).
(Reporter)

Comment 12

9 years ago
Good point about syncing profiles being even better. Should we morph this bug

from:

Weave should allow to select/de-select individual Bookmarks-/Places (incl. Folders) for syncing

to:

Weave should have "Profiles" to allow to select/de-select individual Bookmarks-/Places (incl. Folders) for syncing

Comment 13

8 years ago
One additional reason that I would like this feature is for privacy reasons.  I would like a folder of bookmarks for home use that are never on my work computer (and therefore in the domain of our IT staff; say, job openings).  It also goes the other way, where I am working on something privileged/confidential (but suggested by what I have bookmarked on public sites) and shouldn't have synced on non-secure devices.

These issues would be solved by most solutions above, but would not be solved if everything is synced to the server, downloaded to the client and simply made not-visible.

Comment 14

8 years ago
A nice Idea might be the possibility to add a root point (similar to user accounts on ftp servers). This would provide an easy workaround for including/excluding folders and probably be easier to implement.
(In reply to comment #11) 
> Gary Gendel: How about using tags that can identify groups that you don't want
> to sync?
> 
> Weave could decrypt bookmarks and look for tags/annotations and decide to not
> add the bookmark to the local computer. Not sure yet how it'll interact with
> other clients if one says it's done syncing but didn't actually sync everything
> (on purpose).

I would also like to comment that I for one have completely moved to tag based classification of bookmarks and would definitely need to have a list of tags to (not) synchronize. Tagging instead of foldering in my current view enables better integration with external applications.

I guess this could be solved by a capability to assign certain tags to certain folders (Public; Private), but I am not aware such functionality exists right now in Firefox 3.6.

Updated

8 years ago
Component: General → Sync
QA Contact: general → sync

Comment 16

7 years ago
Any relevance:

Bug 588620 - add shared items to places, provide API for retrieving it

?
< https://bugzilla.mozilla.org/show_bug.cgi?id=588620 >

Comment 17

7 years ago
Any Updated on this? For me this is a blocker. I simply will not use Sync if I don’t have the ability to granularly determine what I want synced

Comment 18

7 years ago
Developers are first working to get it into Firefox in a good way.
Vote for this bug, and they will do something more quickly.

It is not set as a blocker, so not blocking Firefox 4.
Granular control down to the item level is not a priority at this time.  We will continue to evaluate priorities for the evolution of the product, and act accordingly.

Comment 20

7 years ago
Im still using xmarks because of this feature but they are closing down now :(
Please take discussion of this feature to the discussion group:

http://groups.google.com/group/mozilla-labs-weave/browse_thread/thread/d05695ff744524b0#

Bugzilla is not a good place to have general discussions.
Duplicate of this bug: 616226
Duplicate of this bug: 624706

Updated

7 years ago
Duplicate of this bug: 632398
WONTFIXing this, because open bugs that we don't plan to work on are of no use to anyone.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Comment 26

5 years ago
That you don't plan to work on it is hardly a reason to wontfix anytyhing. You never know if someone comes along...
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Updated

5 years ago
Status: REOPENED → NEW
(In reply to Magnus Melin from comment #26)
> That you don't plan to work on it is hardly a reason to wontfix anytyhing.
> You never know if someone comes along...

If someone does come along, neither myself nor the other Sync peers will be approving code that's shaped like this bug to land, so WONTFIX is an accurate resolution.

Our consistent position over the past two years has been that Sync will not be accruing this kind of complexity. That something was considered as a feature request for Weave, four and a half years ago, does not mean that we will consider it for Sync.
Status: NEW → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.