Will not install on Vista over a previous version.

RESOLVED DUPLICATE of bug 404609

Status

Thunderbird
Installer
--
critical
RESOLVED DUPLICATE of bug 404609
10 years ago
10 years ago

People

(Reporter: Robb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; Windows-Media-Player/10.00.00.3990)
Build Identifier: Thunderbird 2.0.14

When I try to install the latest version of Thunderbird I get the following message:
Error opening file for writing:
c:/program files/mozilla thunderbird/mozmapi32.dll
Click to retry or cancel

Reproducible: Always

Steps to Reproduce:
1.Double click installation file.
2.
3.
Actual Results:  
None


I also cannot find Mozzila in the programs and features so I could uninstall the previous version.  If I try to delete the .dll file causing the problems vista tells me I do not have permission.  I am an admin and not a rookie user.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404609
(Reporter)

Comment 2

10 years ago
The supposed duplicate bug has no solution.  Installing to a different folder cannot work because you don't get to pick where it is installing.  The problem occurs well before you can specify an install location.  Also, this is not a solution merely a workaround.  Why can't I modify or uninstall a previous version of Thunderbird?
Resolution: DUPLICATE → INVALID
Choose custom install and you should be able to install into a different location. That bug will also handle the uninstall case.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 404609
(Reporter)

Comment 4

10 years ago
Again the duplicate bug has no resolution.  There is a link to a forum of questions but no response to the question at hand.
Resolution: DUPLICATE → INVALID

Comment 5

10 years ago
That the duplicate bug doesn't have a resolution doesn't make this a dupe, nor should you change the resolution to invalid. It's a dupe! ;) 

We also have bug 340535 which is closely related.

I do think the question was answered in comment 3 here. It's certainly possible to install (using the installer, not through automatic update) into a non standard folder.

Duping... please don't change it back again.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 404609
You need to log in before you can comment on or make changes to this bug.