If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Replying to an email from a MIME digest (.eml) shows gibberish instead of UTF characters in subject line

RESOLVED DUPLICATE of bug 314351

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 314351
9 years ago
9 years ago

People

(Reporter: Filip Miletic, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
I notice this bug when trying to reply to messages from an OpenOffice mailing list which I read in the form of a daily digest.

The messages come bundled in a long MIME-encoded message.  Clicking on any of the  contained messages (seen as attachment when viewing the digest message) allows the particular message to be viewed.

If the subject line of the particular message contains UTF-8 characters, replying to it shows gibberish in the subject line.  UTF-8 characters in the poster's name also show as gibberish in the "<username> wrote:" quotation header.

As an example:
original subject:
Borders из Границе у Ивице, добровољци?
becomes:
Re: Borders 87 @0=8F5 C 28F5, 4>1@>2>YF8?

Comment 1

9 years ago
Please attach a sample digest message (save as .eml) from the list showing the problem.

Do you see the problem with 3.0a1 or a nightly?
(Reporter)

Comment 2

9 years ago
Created attachment 324061 [details]
A sample MIME email that exibits the problem

Comment 3

9 years ago
Yes I can confirm that on trunk. (Though to test one have to forward that message to one self - otherwise they digest mails all open blank.)
Blocks: 269826
Summary: Replying to an email from a MIME digest of OpenOffice mailing list manager shows gibberish instead of UTF characters in subject line → Replying to an email from a MIME digest (.eml) shows gibberish instead of UTF characters in subject line
Probably DUP of Bug 314351. 

Comment 5

9 years ago
Yep, thx wada.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 314351
No longer blocks: 269826
You need to log in before you can comment on or make changes to this bug.