Plain/text message formatting not working with special language characters

RESOLVED DUPLICATE of bug 106028

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 106028
10 years ago
10 years ago

People

(Reporter: Aurimas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; lt; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: 2.0.0.14 (20080421), lithuanian

Plain/text messages are formatted in *bold*, /italic/, _underline_,...
When a word has special language character at the end or beginning, it doesn't work.
Example with lithuanian letter `ė' in case of bold:

*ėatbeginning* - not working
*endingwithė* - not working
*haveėinthemidle* - works


Reproducible: Always

Steps to Reproduce:
1.Write this text into message (lihuanian text, I use UTF-8)
*ėatbeginning*
*endingwithė*
*haveėinthemidle*
2.Save (as draft)
3.View draft in main window (not composer)
4.Same thing with /italic/ and _underline_
Actual Results:  
Last word is shown correctly, firs 2 - not.

Expected Results:  
All 3 words should be in bold.

UTF-8, lithuanian language.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 106028
You need to log in before you can comment on or make changes to this bug.