Right arrow key when disabled submenu item is highlighted expands popup

VERIFIED DUPLICATE of bug 32685

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 32685
18 years ago
10 years ago

People

(Reporter: Blake Ross, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build ID: 2000062408

Click View, highlight Use Stylesheet >.  Now press the right arrow key.  The 
submenu appears, even though Use Stylesheet is disabled.

Comment 1

18 years ago
This is properly disabled on Mac (bug 29349), but linux and win32 allows the
child popup of a disabled parent to display.
Keywords: nsbeta3
OS: Windows 98 → All
Hardware: PC → All
(Assignee)

Comment 2

18 years ago
uhh, yup. doh!
Status: NEW → ASSIGNED
Target Milestone: --- → M21
(Assignee)

Comment 3

18 years ago
not that big of a deal, futuring.
Keywords: nsbeta3
Target Milestone: M21 → Future
(Reporter)

Comment 4

18 years ago
hmm...ok.  trying for rtm if possible, though...will the menu items of a popup 
still function correctly if the parent item is disabled?  if so, couldn't this 
have some unintended effects?
Keywords: correctness, rtm
(Reporter)

Comment 5

18 years ago
oops.  exact dup of 32685.  Pink, could you checkin the patch over there, 
please?

*** This bug has been marked as a duplicate of 32685 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.