add a preference to disable automatic offline detection

RESOLVED DUPLICATE of bug 463046

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 463046
10 years ago
3 years ago

People

(Reporter: beltzner, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Spun out of bug 424626

There's a start in attachment 322620 [details] [diff] [review], but biesi think that code's in the wrong place to be a general pref.
https://bugzilla.mozilla.org/attachment.cgi?id=322620
has been landed in mozilla-central now since it was reviewed and no objection came in.
I'm fine with improving it if needed. Any pointers?

Comment 2

10 years ago
This could have saved me hours of grief after I upgraded my linux system to Fedora 9, and that turned on NetworkManager by default, and FF3 *wrongly* used NM to decide whether my system was online. (I use a cable connection and static addresses.)

The option to turn off automatic offline detection should be very visible in the networking menu.

Thanks.
The pref has been added and defaults to non-automatic detection (IIRC).
So close this as fixed or keep it open for evaluation if there will be UI for it?

Comment 4

9 years ago
is this bug about a cross platform switch or just linux/networkmanager?

Updated

9 years ago
Duplicate of this bug: 436815

Updated

8 years ago
Duplicate of this bug: 538617

Comment 7

8 years ago
@Alexander: same thing happen in Windows.
@Wolfgang: I think better having UI for this preference

I would say that this is an unwanted feature. If offline mode is really necessary, then why it should be automatic? And when it really should be automatic, how come going online mode is not automatic? And why user can not choose their preference over this feature?

Anyway, I use this workaround now: https://addons.mozilla.org/en-US/firefox/addon/13152

Updated

8 years ago
Duplicate of this bug: 557115

Comment 9

8 years ago
We should not have to install an extension to disable unwanted functionality. Such bloat was why FF was forked in the first place.  IMO, offline mode should be the extension, and it should allow for automatically going back online as soon as possible. Who really wants to stay offline after their network connection returns?

Comment 10

8 years ago
When my computer goes on standby or hibernation, firefox stops connecting to pages, even with an active dial-up connection. I'm told to "uncheck work offline mode" when in fact it is already unchecked, and checking and unchecking does not restore browsing function. Only way to restore active browser is complete reboot, reconnection and LOST SESSION WINDOWS! This is a very irritating bug that has wasted countless hours.

Comment 11

8 years ago
This definitely needs to be addressed.  I have apache running on localhost (obviously being offline is irrelevant) and it's really annoying that I have to launch Safari every time I'm away from an internet connection in order to work around this problem.

Comment 12

3 years ago
There is network.manage-offline-status added in bug 463046, turned off by default in bug 620472.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 463046
You need to log in before you can comment on or make changes to this bug.