Mouse buttons released on certain widgets cause problems

VERIFIED DUPLICATE of bug 35606

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 35606
18 years ago
18 years ago

People

(Reporter: pete, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Go to Edit > Preferences... Go to Appearance > Fonts. Click and hold the mouse 
button on "Always use my font settings..." check box, move the cursor to an 
unchecked radio button above it (in my case Serif was checked, Sans Serif was 
unchecked, I released the mouse cursor on Sans Serif). Two radio buttons will 
now be checked. Clicking and dragging from almost anything and releasing it on 
a radio button or checkbox will alternate its checked state.

Comment 1

18 years ago
dup of 35606...this should be fixed now, try it on a new nightly and reopen 
that if it's not

*** This bug has been marked as a duplicate of 35606 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
verified duplicate. In a current build, this is fixed (including both the 
onmouseup state change, and the opportunity to get two radio concurrently 
selected.) [Although it looks this was fixed the day after the m16 branch
was cut, so it may still work this way in M16). 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.