bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

History window is blank

VERIFIED DUPLICATE of bug 53842

Status

()

Core
Document Navigation
P2
normal
VERIFIED DUPLICATE of bug 53842
18 years ago
7 years ago

People

(Reporter: Alek Jeziorek, Assigned: Steve Lamm)

Tracking

({smoketest})

Trunk
All
Windows 98
smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+][nsbeta2-][nsbeta3+] slamm is unable to reproduce.)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
-start browser
-browse a few pages
-tasks|tools|history
- the hsitory will be blank and the pages that u browsed should be there but 
aren't there
linux comm. 2000-06-26-08-M17
(Reporter)

Updated

18 years ago
Keywords: smoketest

Comment 1

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]

Comment 2

18 years ago
Works just fine for me with today's build on Win98 provided you don't try to go 
back from certain frameset pages.  And that's a known bug already on the radar 
for beta 2.  Can you give me a list of URLs that you visit to cause the problem?
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 3

18 years ago
Updating OS to Linux.  Alek, are you seeing this still on Linux?  Is it on other 
platforms?
OS: Windows 98 → Linux

Comment 4

18 years ago
I sense confusion. The functionality is question is the Global History Window. Not the little session history drop-down/pop-ups.
Summary: History pop-up is blank → History window is blank
Yes. this is a global history functionality.
(Reporter)

Comment 6

18 years ago
Still see this on linux commercial build 2000-07-05-08-M17. This happens with 
the bookmark manager too. Is this the same bug or should a new one be filed?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 7

18 years ago
Is this the problem you, me, and rpotts we're talking about earlier today?  That
the code to add SH entries is accidently #ifdef's out?
Priority: P3 → P2
Target Milestone: --- → M18
global history code was ifdeffed out accidentally in today's build. But this 
bug is open from last week.

Comment 9

18 years ago
worksforme on
  linux/mozilla
  linux/commercial
  win32/mozilla

I also tried this on a commerical download build.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

18 years ago
verifying...don't see this anymore on 2000-07-10-08-M17
Status: RESOLVED → VERIFIED
Adding keyword to bugs which already show a nsbeta2 triage value in the status 
whiteboard so the queries don't get screwed up.
Keywords: nsbeta2
(Reporter)

Comment 12

18 years ago
seen on latest linux build 2000-08-10-08-M18; cc: twalker
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
over to slamm..
Assignee: radha → slamm
Status: REOPENED → NEW

Comment 14

18 years ago
I do NOT see this with my 2000081008 Linux build and an established(old) profile.
bug fixed on Mac commm. 2000-08-14-04-M18

Comment 16

18 years ago
I saw a link to this bug on the Windows smoketest report. Dees that mean this is still a problem with today's (08/14) builds AND 

only on Windows?

Yes, I saw this bug again today on mozilla build 2000-08-14-09-M18

Updated

18 years ago
OS: Linux → Windows 98

Comment 18

18 years ago
PR2 is outta here.  Moving from [nsbeta2+] to [nsbeta2-].  Putting on [dogfood+] 
radar and nsbeta3 keyword
Keywords: nsbeta3
Whiteboard: [nsbeta2+] → [dogfood+][nsbeta2-]

Comment 19

18 years ago
reproduced with 2000081508 commercial build on Win98. NOT seen with Linux or Mac builds with same date.
I tried this on another Win98 machine and it did NOT reproduce, so there's something else going on.

Comment 20

18 years ago
I can't reproduce this on my Win98 build.  Can somebody figure out what makes it 
break?
Whiteboard: [dogfood+][nsbeta2-] → [dogfood+][nsbeta2-][NEED INFO]
I saw this again on 2000-08-16-10-M18
still present on Windows 2000-08-17-06-M18
still present on windows commercial build 2000-08-18-04-M18

Updated

18 years ago
Whiteboard: [dogfood+][nsbeta2-][NEED INFO] → [dogfood+][nsbeta2-][nsbeta3+]
(Assignee)

Updated

18 years ago
Whiteboard: [dogfood+][nsbeta2-][nsbeta3+] → [dogfood+][nsbeta2-][nsbeta3+] Ack, this bug sneaked up on me. I hope I can reproduce on winNT or Linux.
(Assignee)

Comment 24

18 years ago
The next time someone sees this bug, be sure to attach your history files from 
you profile (history.mab, history.dat). Do you continue to see the bug if you 
create a new profile?
Whiteboard: [dogfood+][nsbeta2-][nsbeta3+] Ack, this bug sneaked up on me. I hope I can reproduce on winNT or Linux. → [dogfood+][nsbeta2-][nsbeta3+] slamm is unable to reproduce.

Comment 25

18 years ago
Though this is clearly a nsbeta3+ bug, should it really be dogfood+?  Lots of
users don't even now that the history window exists.
works fine on windows build 2000-08-24-06-M18

Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
linux 2000-08-29-08-m18
Mac 2000-08-29-08-m18

seen again on these those build

reopening
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 28

18 years ago
Settin OS to ALL.
Hardware: PC → All
(Assignee)

Comment 29

18 years ago
This still works fine in my build. Is this a debug vs. release build issue?

Tracy, would you attach the history files from you profile directory?
this worked fine on all comm platform builds today

windows 2000-08-30-06-m18
linux 2000-08-30-06-m18
mac 2000-08-30-04-m18

it seems odd it's there some builds and not on others.

Comment 31

18 years ago
Tracy, PLEASE attach those files from your history profile. If you don't know
where those files are or how to attach them, please ask us. We'll gladly help you.
history was fine again on all comm builds

jce2...Yes, I do not know how to find the files you wish attached.  I'd 
appreciate help in doing that.  Thanks

Comment 33

18 years ago
This works fine on all win32, Mac and Linux mozilla builds 0901.  It should 
probably be resolved as WFM.

Comment 34

18 years ago
resolving WFM
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 35

18 years ago
marking VERIFIED WFM
Status: RESOLVED → VERIFIED

Comment 36

18 years ago
Commenting: seeing problem on Windows 98 original (currently on build
2000100308), have been seeing for as long as I can remember, and I just
reinstalled Windows a week ago (problem has been present since before then). PR2
History is also broken. Suggest reopening, because for me this is NOT fixed. I
haven't had a working history since PR1.

Adding Asa CC because he told me to remind him about this problem so that he
could look into it.

Comment 37

18 years ago
I am not seeing this on 100308 Win98 though, nor do I ever remember having this
problem.

Comment 38

18 years ago
Created attachment 16402 [details]
My history.mab file, as requested

Comment 39

18 years ago
Created attachment 16403 [details]
History.dat file, as requested

Comment 40

18 years ago
Reopening with Asa's go-ahead. Still have a blank history here on 100608, Win98.
I have attached my history.dat and history.mab files as was requested earlier. I
hope this helps. Let me know if there's anything else I can do, I really want to
be able to use my History. :)

James
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 41

18 years ago
hmm isn't this being worked on in bug 53842 now?
a "fix in hand" bug titled "History page is displaying a blank window"

Comment 42

18 years ago
Verifying this bug is a dupe of 53842, which has a fix in hand for RTM.


*** This bug has been marked as a duplicate of 53842 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
marking verified per last comment
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.