Default reply header should include timestamp

RESOLVED FIXED in Thunderbird 3.0a3

Status

Thunderbird
Preferences
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: bsterne, Assigned: Magnus Melin)

Tracking

unspecified
Thunderbird 3.0a3
Bug Flags:
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
It is very useful to include a timestamp for messages to which a reply is being sent.  I was able to search around in the config editor for mailnews.reply_header_authorwrote and use a search engine to figure out that I needed to set this value to 2.

I think we should set the default pref to 2 and additionally add UI that would make this preference discoverable and configurable.
Flags: wanted-thunderbird3?

Comment 1

9 years ago
Bryan, what do you think about changing this default? I doubt we want UI for this pref, though.
Seems like it could be a good change.  What does the timestamp read like?

On the configuration side i'd love to promote and help extensions that allow for editing this as some kind of template.  But I don't we need a default pref UI for it.
(Reporter)

Comment 3

9 years ago
I just realized that I indicated the wrong pref in my initial comment.  The actual pref in question here is mailnews.reply_header_type.

With this set to 2, the header looks like:
On 08/26/2008 01:42 PM, Brandon Sterne wrote:

With the default value of 1, the header just says:
Brandon Sterne wrote:
That looks ok to me, if there was a patch i'd put in for it.
(Assignee)

Comment 5

9 years ago
Taking. I've been using this for years my self!
Assignee: nobody → mkmelin+mozilla
Flags: wanted-thunderbird3? → wanted-thunderbird3+
Target Milestone: --- → Thunderbird 3.0b1
(Assignee)

Comment 6

9 years ago
Karsten, are you interested in mailnews.reply_header_type=2 for seamonkey too?

Comment 7

9 years ago
No, please don't change our default. :)
(Assignee)

Comment 8

9 years ago
Created attachment 337710 [details] [diff] [review]
proposed fix

Ok, let's see if I can tempt Phil with a thunderbird only patch then  :)
Attachment #337710 - Flags: review?(philringnalda)
(Assignee)

Updated

9 years ago
Status: NEW → ASSIGNED
Attachment #337710 - Flags: review?(philringnalda) → review+
Comment on attachment 337710 [details] [diff] [review]
proposed fix

Sure, you've got plenty of ui-r, and I can't argue with the code :)
(Assignee)

Comment 10

9 years ago
changeset:   330:6ac5fb23522e
http://hg.mozilla.org/comm-central/rev/6ac5fb23522e

->FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Duplicate of this bug: 465959

Updated

9 years ago
Duplicate of this bug: 472288

Updated

9 years ago
Duplicate of this bug: 509796

Comment 14

8 years ago
First of all, I still prefer the previous default of mailnews.reply_header_type=1 because it is minimalist:  IMO, including the timestamp is unnecessarily verbose.

In any case, I think mailnews.reply_header_type=2 is (currently) illogical because, AFAICT, it uses the user’s local time zone without including the UTC offset.  This makes sense only if all of the user’s correspondents are in the same time zone.  Since such a situation is rare, the reply header should include the UTC offset.  Names of time zones, such as PDT for -0700, should not be used because time zones, especially DST rules, frequently change for political reasons.
You need to log in before you can comment on or make changes to this bug.