ctrl + tab and tab closing needs to revert to previous active tab first

RESOLVED DUPLICATE of bug 395980

Status

()

defect
RESOLVED DUPLICATE of bug 395980
11 years ago
11 years ago

People

(Reporter: leeoniya, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008061008 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008061008 Minefield/3.0pre

the current tab behavior is not what one would expect, and is not particularly useful.

ctrl+tab needs to revert to the previously active tab before cycling from the beginning. the current implementation makes it impossible to go back and forth between 2 tabs without using the mouse...optionally it may even be better to have ctrl+tab cycle the tabs backwards by last active timestamp, which would most likely be preferable since the most recently active tabs are probably most relevant to the user.

also, when closing a tab, the focus needs to be reverted, again to the most recently active tab, not the tab "before" the closed one, this too, is not useful and not intuitive.

Reproducible: Always

Comment 1

11 years ago
Dup of bug 395980 for when you press Ctrl+Tab and bug 217563 for when you close a tab.  Looks like the plan is to fix bug 395980 but not bug 217563, which strikes me as an odd combination.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395980
You need to log in before you can comment on or make changes to this bug.