Bug 217563 (focusLastTab)

When closing a tab, activate the previously visited tab instead of the rightmost one (focus last selected tab on close)

VERIFIED WONTFIX

Status

()

--
enhancement
VERIFIED WONTFIX
15 years ago
9 months ago

People

(Reporter: raspl, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Say you have 3 pages open in individual tabs, you are currently on the 2nd tab.
Now you open a link on that page in a new tab and change (from the 2nd) to that
new 4th tab. After checking it out, you close that 4th tab.
Now what happens?
You find yourself on the 3rd tab. But what you really want to do is to continue
where you left off - which would be the 2nd tab!
So in short, Firebird should remember the latest visited tabs and, when closing
a tab, take you to the previous one instead of the rightmost one.

Reproducible: Always

Steps to Reproduce:
1. open 4 pages in tabs
2. activate the 2nd tab
3. now switch to the 4th tab
4. close the 4th tab

Actual Results:  
you are on the 3rd tab

Expected Results:  
you should be on the 2nd tab

Comment 1

15 years ago
Intended behaviour.
Download tabbed browsing extension to change tab behaviour
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: General → Toolbars
OS: Linux → All
QA Contact: asa → bugzilla
Hardware: PC → All
Resolution: --- → WONTFIX

Comment 2

15 years ago
*** Bug 246003 has been marked as a duplicate of this bug. ***
*** Bug 277285 has been marked as a duplicate of this bug. ***
Better choice now: install "Focus Last Selected Tab" extension, which does that
and just that.
*** Bug 280710 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
Summary: When closing a tab, activate the previously visited tab instead of the rightmost one → When closing a tab, activate the previously visited tab instead of the rightmost one (focus last selected tab on close)
*** Bug 286172 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
There is a lastTabSelected plugin that fixes this "bug" (for the ones who 
don't want to wait).
*** Bug 301256 has been marked as a duplicate of this bug. ***
*** Bug 302789 has been marked as a duplicate of this bug. ***
Alias: focusLastTab

Comment 10

13 years ago
*** Bug 342705 has been marked as a duplicate of this bug. ***

Updated

13 years ago
QA Contact: bugzilla → toolbars

Comment 11

13 years ago
Wouldn't it be more intuïtive just to add a "last tab selected"-option to the preferences rather then keep adding duplicates for this bug?

The fact that there are 7 duplicates should mean something.

I personally don't have a problem with using the extionsions but I'm sure there are other users that never install extensions, just because they don't know how to and this is standard navigation functionality, nothing fancy.

(IMHO)

GJ

Comment 12

12 years ago
*** Bug 348687 has been marked as a duplicate of this bug. ***
*** Bug 351979 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Duplicate of this bug: 425356

Updated

11 years ago
Duplicate of this bug: 427343

Comment 16

11 years ago
"Intended behaviour." does not really explain why it is intended. we know it's intended - otherwise it would not be working this way consistently.

i see no value/usefulness for this current "intended" default and only behavior.

any chance of re-evaluating the status of this bug on account of mounting duplicates?

thanks,
Leon
i'm also not particularly agreeing with this intended default. in combination with bartab extension which allows unloaded tabs, quite often an unrelated unloaded tab sits right next to my currently active tab. this active tab has just been openeed from a "central" google reader tab or similar. now i close the active tab and focus switches to next unrelated, unloaded tab, making the contents of it load even when i have no such intention at that moment. most of the time %, i want to get back to my central newsreader tab.

i guess it might be a border case, so solved-with-extension worksforme. just chiming in anyway.

Comment 18

3 years ago
I too would like to know why this is the intended result and add my support for the default behavior to be opening the previously selected tab. I'd also love shortcuts to move through tab history in addition to and separate from tab layout.

Updated

9 months ago
Duplicate of this bug: 1431338
You need to log in before you can comment on or make changes to this bug.