bug in the handling of the duplicate keywords in Search Engine manager

RESOLVED DUPLICATE of bug 429091

Status

()

RESOLVED DUPLICATE of bug 429091
11 years ago
11 years ago

People

(Reporter: pre.adrien, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9) Gecko/2008052906 Firefox/3.0


It is impossible to change the keywords affected to search engines if the keyword was previously used. (see "steps to reproduce").





Reproducible: Always

Steps to Reproduce:
1. open the menu to manage the search engine of the "find toolbar"
2. Assign the key word "gg" to google. Then close the "manange window"
3. Open the same window again. Try to assign the keyword "gg" - the same as previously used for google -  to one other search engine, lets say yahoo.
4. The error window appear. This is normal.
5. Now, change the keyword affected to google with "g". 
6. Without closing this window, try to affect the keyword "gg" to yahoo.

Now, I expect firefox to setup the keyword "gg" to yahoo, because it is currently not used anymore. BUT to do it, you have to close the "manage window" and open it again.
Actual Results:  
I expect firefox to refresh the keyword list as it is modified, not as the window is opened.

Expected Results:  
The keyword list is only changed if the manage window is opened.

Nice Job for Firefox 3!
Many thanks for this great peace of software.
Find toolbar is the name of the bar on the bottom of your screen (ctrl+f).
Component: Find Toolbar / FastFind → Search
QA Contact: fast.find → search
Summary: bug in the handling of the duplicate keywords in the find toolbar → bug in the handling of the duplicate keywords in Search Engine manager
Version: unspecified → 3.0 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008060807 Minefield/3.1a1pre

It happens indeed as described. I don't know if Bug 386437 will take care of this problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429091
You need to log in before you can comment on or make changes to this bug.