Support for Solaris x86/SPARC

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Administration
P5
enhancement
RESOLVED WONTFIX
10 years ago
2 years ago

People

(Reporter: dbo, Unassigned)

Tracking

unspecified
Future
Sun
All

Details

(Reporter)

Description

10 years ago
It would be really cool if AMO could support Solaris (both x86 and SPARC). At least the calendar project does releases for that platform regularly.
Depends on: 427098

Comment 1

10 years ago
Justin, will bug 427098 fix this?
Justin, should this even just be a DUP of bug 427098?
duping to Bug 427098
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 427098
Component: Add-ons → Administration
QA Contact: add-ons → administration
This is not a dupe of bug 427098. That bug asked for the raise of the platform limit to more than three platforms.

Thus bug asks, that two separate Solaris platforms (x86 and SPARC) are added instead of just a general Solaris platform. For an extension like Lightning that ships binary components, we have to release one .xpi for each Solaris package.

The alternative would be to manually glue the two platform xpi files together (like a unified binary for the Mac), but that is a lot of pain and we would really like to avoid this in the future.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Priority: -- → P5
Target Milestone: --- → Future
Based on the current usage of platforms other than Windows, Mac, and Linux by add-ons on AMO, we'll actually be dropping BSD and Solaris in the upcoming Developer Tools revamp.

So we're not really interested in adding these additional platforms. If specific support for them is truly needed, I think those files won't be able to be hosted on AMO.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago7 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.