Status Bar leaving stray pixels under specific conditions (Windows Classic Style, Forecastfox extension)

RESOLVED DUPLICATE of bug 417259

Status

()

Firefox
General
--
trivial
RESOLVED DUPLICATE of bug 417259
10 years ago
10 years ago

People

(Reporter: Harry Sintonen, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.9) Gecko/2008052906 Firefox/3.0

The status bar leaves behind some stray pixels, if you use Windows Classic Style theme, ClearText (AA) font rendering and Forecastfox extension. Usually it happens if you quickly hover over other links after clicking one.

The bug has been present in all FF3RC versions (1,2,3).

Reproducible: Always

Steps to Reproduce:
1. Set Windows XP to Windows Classic Style and enable ClearText.
2. Install Forecastfox extension. Configure the forecast panel to appear at the navigation bar (see the the screenshot).
3. Open page with lots of links. Click one while quickly moving the mousepointer over some other links (making the link destination appear in the statusbar). You might need to repeat couple of times to get the effect visible.
Actual Results:  
After the link opens and the browser renders "Ready" ("Valmis" in finnish locale) to the statusbar, you should see stray pixels left on the bottom row of the status bar. See the attached screenshots.

Expected Results:  
There should be no stray pixels left on the status bar.

This bug might be related to #417259.
(Reporter)

Comment 1

10 years ago
Created attachment 324916 [details]
Screenshot #1 of the statusbar displaying the stray pixels
(Reporter)

Comment 2

10 years ago
Created attachment 324917 [details]
Screenshot #2 of the statusbar displaying the stray pixels, also displays the Forecastfox extension panel positioning (if it should matter)
(Reporter)

Updated

10 years ago
Summary: Status Bar leaving stray pixels under specific conditions (Windows Classic Style, ClearText fonts, Forecastfox extension) → Status Bar leaving stray pixels under specific conditions (Windows Classic Style, Forecastfox extension)
Version: unspecified → 3.0 Branch
(Reporter)

Comment 3

10 years ago
Actually it also happens with ClearText disabled, so that's no requirement. I can't get it reproduced with standard XP theme, however.

Comment 4

10 years ago
This is triggered by any extension that tries to hide horizontal overflow when used on an XUL element that contains borders.  It just so happens to that Windows Classic status bar panels are bordered (but not in most other themes), so that's why it's triggered there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 417259
You need to log in before you can comment on or make changes to this bug.