Mail searching engine should also check "From" and "Subject" when searching in "Whole message"

RESOLVED DUPLICATE of bug 271222

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 271222
10 years ago
10 years ago

People

(Reporter: Alakdae, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.8.1.14) Gecko/20080425 Firefox/2.0.0.14
Build Identifier: wersja 2.0.0.6 (20070823)

Searching using "Whole message" option should also include the "From" and "Subject" fields in it's search. For now if you receive a message with subject "helicopter", but the body will not contain the word "helicopter", then if you search with either "Subject" or "From and Subject" you will see the message. But if you search for the word "helicopter" with "Whole message" then the message will not be found.

Reproducible: Always

Steps to Reproduce:
1.Search for a phrase with "Whole message" option
2.Search for the same phrase with "From and Subject" option
3.Different results will appear (not showing messages that have the phrase in either Subject or From field)
Actual Results:  
Different results appear (not showing messages that have the phrase in either Subject or From field, but don't contain it in the message body.

Expected Results:  
"Whole message" option should search in WHOLE message including the Subject and From fields.
Or rename the search option as "Message body" and create another one that searches in the message body only.

For now when I need to find a message I need to search 2 times. Once with "whole message" option and the second time with "Subject and From"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 271222
You need to log in before you can comment on or make changes to this bug.