Closed Bug 439227 Opened 12 years ago Closed 12 years ago

Default sort order for search results discriminates against new add-ons (again)

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: ecfbugzilla, Assigned: wenzel)

References

()

Details

A search for "adblock" will give you the actual Adblock extension (this is ok), the following results will be sorted by add-on ID however. This has the result that barely Adblock-related add-ons like StatusBars, ImgLikeOpera or Quick Preference Button come before Adblock Plus.

Note that changing sort order to "Newest" (which hardly anybody will do) doesn't help - this displays add-ons with higher add-on ID first rather than sorting by time of last update.

Please stop using the submission date of an add-on (aka add-on ID) for sorting - it is absolutely meaningless. If you want to sort by date, sort by last update.
Target Milestone: --- → 3.4.6
Assignee: nobody → fwenzel
Duplicate of this bug: 378657
Wladimir: I am not sure I can confirm this? The sort order is determined by the relevance score assigned by MySQL's fulltext search. Adblock plus shows up almost at the very top:

https://addons.mozilla.org/en-US/firefox/search?q=adblock&cat=all

The reason why other add-ons show up on the first page as well is because we are displaying all public add-ons before all sandboxed ones, even if the latter match the search text more closely (there's probably room for improvement there, I admit).

In the patch I put in for bug 378657, exact name hits will now show up on the very top again (further ensuring that ABP shows up far on the top when you search for "adblock", as this is the most intuitive behavior).

Can I mark this bug fixed, or do you see something else missing?
The sort order changed again - so I guess the bug can be resolved WORKSFORME.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
All right, thanks. I seem to remember there was a bug in the advanced search code at the beginning, which probably screwed up the sort order.
Summary: Default sort order for search results discriminates new add-ons (again) → Default sort order for search results discriminates against new add-ons (again)
Verified worksforme; the search order seems fine to me.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.