Thunderbird 3.0 in si - Sinhala

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
11 years ago
8 years ago

People

(Reporter: iamsarves, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(9 attachments, 2 obsolete attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Thunderbird 3.0

We are from Sri Lanka and we already done with Thunderbird 2.x for 'si' (bug id :294435) and now we would like to work on Thunderbird 3.0.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Sarves, as far as I can see the si team has CVS access. Therefore I recommend that you just check in what you've got and then work with the compare-locales out put from your tinderbox to get all the kinks sorted out.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

11 years ago
CCing Danishka, the registration bug for Sinhala is bug 294435.

There are probably a few other bugs missing to depend on. As said on irc to Sarves and Danishka, you folks will need to get together and work something out.
Depends on: 294435

Comment 3

11 years ago
Created attachment 327785 [details]
Thunderbird 2  l10n-source files - Sinhala

Danishka,

These are the localised sinaha source files for Thunderbird 2. Could you please upload this as you have CVS access. I will take care of compare-locale output.

regards,
Rohana.

Comment 4

11 years ago
Rohana,
yes, I will do it.
and you don't want to translate all the stuff, as I have translated earlier.
will update you once I landed the translation.

Comment 5

11 years ago
Created attachment 331618 [details]
latest l10n-Sinhala source files for Thunderbird 2

Danishka,

I made some changes to the Thunderbird 2 l10n-Sinhala Source files (Attachment-327785). The compare-locale process gave me a good result. Could you please upload this to CVS as soon as possible. I will take care of compare-locale output.
Attachment #327785 - Attachment is obsolete: true

Comment 6

11 years ago
Created attachment 333541 [details]
Thunderbird3 - l10n source files - Sinhala

Thunderbird 3 l10n source files localized to Sinhala.

pl. help uploading this to right place and making Sinhala Thunderbird available for Thunderbird 3.0beta, Thanks.

Comment 7

11 years ago
As Thunderbird 2 Sinhala-l10n files are in CVS repo, can we get a tinderbox build setup created for si in 1.8 branch and in Trunk Thunderbird, pl.
We will not add Sinhala to the Thunderbird 2 tinderboxen so late in the release cycle. Sorry for that, but we just do not have the cycles to QA these bits for the next security releases. I suggest that you release language packs for your community.

I will add Sinhala to the list of supported locales for Thunderbird 3 once we have working l10n builds from hg (Mercurial) and once I have setup my local Mercurial environment.

Comment 9

10 years ago
The "Comparison for mail-si" (http://l10n.mozillamessaging.com/buildbot/compare/hg-langpack/409) suggests me that the Repo contains thunderbird 2-l10n source files. Pl. someone can upload tb3-l10n source files attached in this bug to the repo. This will greatly help us as we are now making changes to l10n source for Beta1, thanks.

Comment 10

10 years ago
Created attachment 340074 [details]
Thunderbird3-Beta1 l10n source files -Sinhala

These are the Thunderbird3-Beta1 l10n source files for Sinhala Locale. Can someone pl. upload this to the repo, Thanks.
Attachment #333541 - Attachment is obsolete: true
Component: Build Config → si / Sinhala
Product: Thunderbird → Mozilla Localizations
QA Contact: build-config → sinhala.si

Comment 11

10 years ago
I will take care of it. :)

Comment 12

10 years ago
I have already translated components other than mail/ and editor/.
so, i have updated mail and editor few min; ago ;-)

Comment 13

10 years ago
Sinhala has a great solution coming from bug id=450151
It does not need Localizing which is better and makes Sinhala universally usable. It's a transliteration solution. I have tested it and Shredder does it great. I use US-International keyboard.

May I suggest the Nightly build at:
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/

A font is available at:
http://www.americansmartfonts.com/download/

This appears to me an unbeatable solution for Sinhala. It seems to me as SVG standard is adopted by more apps as by Mozilla, Uniscribe and Pango and all these rendering engines would be confined to the Unicode fonts of Abugida alphabets.

Comment 14

10 years ago
(In reply to comment #12)
> I have already translated components other than mail/ and editor/.
> so, i have updated mail and editor few min; ago ;-)

If so, other-licenses/branding/thunderbird should also be there. thanks.

Comment 15

10 years ago
yes, other-licenses/branding/thunderbird was there
Danishka, it seems that you committed to the cvs trunk, instead of l10n-central on hg. Please commit your stuff again, this time to hg. Thanks!

Comment 17

10 years ago
sure! will do it.

Comment 18

10 years ago
According to Comparison for mail-si (Build 3381 from Fri Sep 26 03:45:53 2008 )

http://l10n.mozillamessaging.com/buildbot/compare/hg-langpack/3381

It indicates many number of missing files but the source files which I submitted to this bug for Beta1 contains all most all files of those indicated. Could someone pl. help me to resolve this? Thanks.

Comment 19

10 years ago
Rohana, 
last night it was updated but latest build [1] showing something else 

I am working on it.


[1] http://l10n.mozillamessaging.com/buildbot/compare/hg-langpack/3424

Comment 20

10 years ago
landing is fine.

Comment 21

10 years ago
Created attachment 340529 [details]
The two files which show errors in comparison

These are the two files which show errors in comparison, (messenger.dtd and  imapMsgs.properties)

http://l10n.mozillamessaging.com/buildbot/compare/hg-langpack/3553

BTW, According to this, still indicating missing files.

Comment 22

10 years ago
removed all obsolete files and strings. 
I will be fixing existing Errors in imapMsgs.properties and messenger.dtd

@imapMsgs.properties
Unparsed content " ‍ " at 9367-9370

@messenger.dtd
Unparsed content "‍" at 576-577

Comment 23

10 years ago
Axel and Simon,

What do you think about missing and obsolete stuff in toolkit/chrome?

I think obsolete strings for the Tb 3.0 are required for the Fx 3.1 :)

---------------------------------------------
toolkit/chrome
mozapps/plugins/plugins.dtd
blockedPlugin.label
disabledPlugin.label
places/places.properties
bookmarksLivemarkFailed - obsolete
bookmarksLivemarkLoading - obsolete

Comment 24

10 years ago
(In reply to comment #22)
> removed all obsolete files and strings. 
> I will be fixing existing Errors in imapMsgs.properties and messenger.dtd
> 
> @imapMsgs.properties
> Unparsed content " ‍ " at 9367-9370
> 
> @messenger.dtd
> Unparsed content "‍" at 576-577

The attachment above contains error-free those two files. Just upload pl.

Comment 25

10 years ago
(In reply to comment #22)
> removed all obsolete files and strings. 
> I will be fixing existing Errors in imapMsgs.properties and messenger.dtd
> 
> @imapMsgs.properties
> Unparsed content " ‍ " at 9367-9370
> 
> @messenger.dtd
> Unparsed content "‍" at 576-577

done!

Comment 26

10 years ago
I have replaced your files.
Let me check it few minutes later.

latest comparison is 3596 [2]

[2] http://l10n.mozillamessaging.com/buildbot/compare/hg-langpack/3596

Comment 27

10 years ago
(In reply to comment #26)
> I have replaced your files.
> Let me check it few minutes later.
> 
> latest comparison is 3596 [2]
> 
> [2] http://l10n.mozillamessaging.com/buildbot/compare/hg-langpack/3596

According to the latest comparison
 
http://l10n.mozillamessaging.com/buildbot/compare/hg-langpack/3682

it still indicates errors in those two files but my compare-locale does not suggest (hope, above-attached two files are OK).

We should remove "contentAreaCommands.dtd" and "utilityOverlay.properties" from "mail/chrome/communicator". I will look at "messenger.properties" for the missing string. Thanks.

Comment 28

10 years ago
wait I have already fixed them (utilityOverlay.properties and contentAreaCommands.dtd). But it is not updating at the same time.

As I said I a working on this.
Hope fully we can fix all the issues before COB 'PDT'. :)

Comment 29

10 years ago
(In reply to comment #28)
> wait I have already fixed them (utilityOverlay.properties and
> contentAreaCommands.dtd). But it is not updating at the same time.
> 
> As I said I a working on this.
> Hope fully we can fix all the issues before COB 'PDT'. :)

Thanks, I will attach two files which update to fix missing string in mail/chrome/messenger

Comment 30

10 years ago
Created attachment 340552 [details]
two updates file into mail/chrome/messenger

These two for mail/chrome/messenger/

messenger.properties and msgHdrViewOverlay.dtd.

Comment 31

10 years ago
(In reply to comment #23)
> Axel and Simon,
> 
> What do you think about missing and obsolete stuff in toolkit/chrome?
> 
> I think obsolete strings for the Tb 3.0 are required for the Fx 3.1 :)
> 
> ---------------------------------------------
> toolkit/chrome
> mozapps/plugins/plugins.dtd
> blockedPlugin.label
> disabledPlugin.label
> places/places.properties
> bookmarksLivemarkFailed - obsolete
> bookmarksLivemarkLoading - obsolete

just now noticed. fixing this issue required for the Fx 3.1 as well.

Fixed it!

Comment 32

10 years ago
fixed messenger/messenger.properties

Comment 33

10 years ago
Thanks to wladow and cedric, eagle eyes :)

still checking issue in both imapMsgs.properties and messenger.dtd

Comment 34

10 years ago
Created attachment 340706 [details]
a modified file (imapMsgs.properties)

According to

http://l10n.mozillamessaging.com/buildbot/compare/hg-langpack/4628

If you are still struggling, pl. just check with this file. Thanks.

Comment 35

10 years ago
Yes, I was struggling last night till 2.30AM.
I was able to fix them as wladow and cedric helped me.

The missing string was removed purposely. (to check the error)
and dashboard was not updated at same time and I slept as I worked 20hrs continuously .

Yes, now you might think now I am struggling for a small thing. lol

Comment 36

10 years ago
(In reply to comment #35)
> Yes, I was struggling last night till 2.30AM.
> I was able to fix them as wladow and cedric helped me.
> 
> The missing string was removed purposely. (to check the error)
> and dashboard was not updated at same time and I slept as I worked 20hrs
> continuously .
> 
> Yes, now you might think now I am struggling for a small thing. lol

Thanks, you and both others.

Yes, Hope, you, as a technical guy, can understand term "struggle" correctly in the technical arena.

Comment 37

10 years ago
you can't see the change once I committed, please wait till it update :)

Comment 38

10 years ago
no worries dude!

Comment 39

10 years ago
green for the si :)

Comment 41

10 years ago
Simon,

I think we have to remove the Tb translation for the 'installation'.
Shall I revert it to the en-US?
Danishka,
I'm sorry but I have no idea what you are talking about. Can you please elaborate?

Comment 43

10 years ago
(In reply to comment #41)
> Simon,
> 
> I think we have to remove the Tb translation for the 'installation'.
> Shall I revert it to the en-US?

Danishka,

Could you just mention what is wrong with it?, pl.

Comment 44

10 years ago
(In reply to comment #42)
> Danishka,
> I'm sorry but I have no idea what you are talking about. Can you please
> elaborate?

Simon, 

AFAIK Sinhala is not supporting for Windows Code pages.
I think Tb-Win-si build should be burning right now ;-)

PS:
I revert Fx translation as per Axel's advice.

Comment 45

10 years ago
(In reply to comment #43)
> (In reply to comment #41)
> > Simon,
> > 
> > I think we have to remove the Tb translation for the 'installation'.
> > Shall I revert it to the en-US?
> 
> Danishka,
> 
> Could you just mention what is wrong with it?, pl.

Rohana, 

Did you tested Tb installation on Windows? pls do
I am not talking about playing with xpi (language_pack).

1st try to find a Tb installer for windows.
ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-central-l10n/

Comment 46

10 years ago
(In reply to comment #45)
> (In reply to comment #43)
> > (In reply to comment #41)
> > > Simon,
> > > 
> > > I think we have to remove the Tb translation for the 'installation'.
> > > Shall I revert it to the en-US?
> > 
> > Danishka,
> > 
> > Could you just mention what is wrong with it?, pl.
> 
> Rohana, 
> 
> Did you tested Tb installation on Windows? pls do
> I am not talking about playing with xpi (language_pack).
> 
> 1st try to find a Tb installer for windows.
> ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-central-l10n/

I am aware what you are talking about and have no problem of just removing a few strings, if its the only solution.

Comment 47

10 years ago
we have to revert only mail/installer/

There are many locales having this issue.
Don't worry Rohana :)

Comment 48

10 years ago
fixed!

Comment 49

10 years ago
Created attachment 348527 [details]
Updated mail and editor files of TB3-Beata1 for Sinhala

These are the mail and editor files for Thunderbird 3 Beta1. As a many number of files having changes, whole directories are uploaded.pl. help to put them on the place.Thanks.

Comment 50

10 years ago
done

Comment 51

10 years ago
there are few obsolete files and strings.
any way, I will fix it 

editor/ui/chrome/composer/editorNavigatorOverlay.dtd
mail/chrome
communicator/contentAreaCommands.properties
messenger
fieldMapExport.dtd
shellservice.properties
virtualFolderName.dtd
messenger-newsblog/newsblog.dtd

Comment 52

10 years ago
Thanks.

But, compare-locale running at my PC did not suggest. I will check my one again.

Comment 53

10 years ago
(In reply to comment #51)
> there are few obsolete files and strings.
> any way, I will fix it 
> 
> editor/ui/chrome/composer/editorNavigatorOverlay.dtd
> mail/chrome
> communicator/contentAreaCommands.properties
> messenger
> fieldMapExport.dtd
> shellservice.properties
> virtualFolderName.dtd
> messenger-newsblog/newsblog.dtd

These obsolete files are not included in that attachment.

Comment 54

10 years ago
no worries, you can find the latest build
i will remove obsolete stuff ASAP.

Comment 55

10 years ago
Created attachment 349934 [details]
Updated messenger.dtd and messenger.properties files

Comment 56

10 years ago
Created attachment 351115 [details]
update abCardOverlay.dtd according to bug 467511

This is the updated file according to bug 467511. Pl. put this in the repo.

Comment 57

10 years ago
Created attachment 362203 [details]
mail/Editor files for TB3 Beta2

Danishka,

These are the mail/editor files for TB3 Beat2. pl. push to hg repo.Thanks.

Comment 58

10 years ago
last night I have updated all the files (changeset eac321cfb40a)  
after that comparison was [1] showing 94 missing strings, after that I have added following files (changeset 77f7cf80b921).  now wait till the dashboard updates it.

aboutRights.dtd
aboutRights.properties
activity.dtd
activity.properties

[1] http://l10n.mozilla.org/buildbot/compare/hg-comm-langpack/15620

Comment 59

10 years ago
ok, now its showing 80% translation with 0 missing strings with green :)

Comment 60

10 years ago
updated mail dir with string changes and removed obsolete files (changeset-149d814bd0e1)

L10n dashboard is now (for the moment) green for si-tb30x.
Marking this as FIXED since Sinhala was already part of the Thunderbird 3
beta2 release.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.