Closed Bug 439544 Opened 14 years ago Closed 14 years ago

Right click on bookmarks menu closes the menu and is passed to the browser area

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 404766

People

(Reporter: to.oliveira, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0

There are times when trying to activate a context menu over an item in the bookmarks menu, the bookmarks menu is dismissed and a context menu apears for the browser content area instead.

There are two diferent situations where this hapes but I believe that they might be related to each other. One is always reproducible, whereas the other one still seems random to me as I can't figure out a way of reproducing it reliably.

Reproducible: Always

Steps to Reproduce:
a) ( this is reliably reproducible )
1- Activate the bookmarks menu
2- right click on one item: a context menu should apear with the usual options ( new bmrk, new folder, delete, etc etc)
2- right click on a second item of the bookmarks menu
* I was expecting that the first context menu be dismissed and that a second context menu would apear related to the secondly clicked item
** however, the first context menu is dismissed, the bookmarks menu is dismissed as well and the second right click seems to be passed to the browser content area, showing a context menu with the usual ( back , forward, reload, etc, etc)

b) Doesn't trigger the bug every time. I'm still trying to find a way, but if tried enough times the bug should come up too..
1. Open the bookmarks menu
2. Right click one item
* the same incorrect bevaviour hapens ( dismissed bookmarks menu + context menu in content area)
Actual Results:  
The bookmarks menu is closed and a context menu apears in the content area.

Expected Results:  
A context menu for the right clicked bookmark should apear and the bookmarks menu should remain visible.

I'm using the FF3 default theme and no other themes are installed.

These are my currently installed add-ons:
1 click weather ( disabled becaude it's incompatible )
adblock  Filterset.G updater
adblock Plus
Foxmarks
Openbook
Web developer
The first issue is a duplicate of Bug 404766. The second issue is not reproducible for me on Windows XP latest 3.0 branch build. Did you try safe-mode?
Yes, I just tried it in safe mode and it hapened as well.
second issue is WFM for me too, so marking dupe of the first
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404766
You need to log in before you can comment on or make changes to this bug.