Closed Bug 404766 Opened 12 years ago Closed 11 years ago

Right-Mouse click twice closes Bookmarks menu/toolbar, instead of open another context menu for a bookmark item

Categories

(Core :: XUL, defect, minor)

defect
Not set
minor

Tracking

()

VERIFIED FIXED
mozilla1.9.2a1

People

(Reporter: lvangoe, Assigned: enndeakin)

References

(Depends on 1 open bug)

Details

(Keywords: ue)

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112005 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112005 Minefield/3.0b2pre

Bookmarks menu closes if you right mouse click a bookmark in menu more than once

Reproducible: Always

Steps to Reproduce:
1.Open book marks menu
2.Right mouse click any bookmark
3.Right mouse click same bookmark again
4.Menu should have closed
Actual Results:  
No errors reported, menu will just close

Expected Results:  
Not close menu, presumably
When I right click on a bookmark in the menu with the current nightly in Windows, I get a context menu. If I do it again, I get the context menu again but the bookmark menu dismisses. 

This is in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112106 Minefield/3.0b2pre.

In the Mac build, I don't even get a context menu. When I right click the first time, it opens the bookmark.This is in Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b2pre) Gecko/2007112104 Minefield/3.0b2pre.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Right clicking a second time I get not the same context menu but the one of the underlying part of the page.
I think it should just dismiss the previous context menu and show a new one.
Component: Bookmarks → XP Toolkit/Widgets: Menus
Product: Firefox → Core
QA Contact: bookmarks → xptoolkit.menus
Summary: Right-Mouse click twice closes Bookmarks menu → Right-Mouse click twice closes Bookmarks menu/toolbar
Duplicate of this bug: 419602
Same even happens with Firefox 2.
Version: unspecified → Trunk
This is probably going to be due to 390621...although that bug says no context menu is popping up, whereas this one has the menu closing entirely.

BTW, confirmed on Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008062219 (Gentoo) Firefox/3.0
Duplicate of this bug: 436206
(In reply to comment #0)
> 3.Right mouse click same bookmark again

The bug happens also if you right-click on another bookmark item.

Can it be reproduced on a PowerPC?
Keywords: qawanted, ue, uiwanted
OS: Windows XP → All
Summary: Right-Mouse click twice closes Bookmarks menu/toolbar → Right-Mouse click twice closes Bookmarks menu/toolbar, instead of open another context menu for a bookmark item
Whiteboard: [reproducible on PowerPC?]
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: xptoolkit.menus → xptoolkit.widgets
Duplicate of this bug: 439544
Duplicate of this bug: 414407
It also happens if you left click anywhere on the Bookmarks menu
Duplicate of this bug: 467871
Duplicate of this bug: 390621
Originally, the behavior as described in bug 390621 could be seen, but now the behavior as described in this bug can be seen.
This changed between 2007-11-08 and 2007-11-09:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-11-08+04&maxdate=2007-11-09+06&cvsroot=%2Fcvsroot
Probably the patch from bug 399468 changed this behavior.
Depends on: 399468
Keywords: qawanted
Duplicate of this bug: 468551
Duplicate of this bug: 476173
Attached patch possible patch (obsolete) — Splinter Review
This patch fixes this so that only the context menu closes up when clicking on the parent menu. It should allow context-clicking another item to close the existing context menu and bring up the context menu for the other item instead.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Any chance on getting this approved and checked in for testing on trunk?

~B
There are builds at https://build.mozilla.org/tryserver-builds/2009-04-21_08:59-neil@mozilla.com-menucloser that can be used for testing. It would be good if people tested this out on various platforms to see how they like it.

Essentially, testing opening the bookmark menu/submenus and context menus and clicking on various other menus/ui to ensure nothing unusual happens.
Yes, Neil, your build has the menu behaving as it should. 
- Right-click anywhere in "Bookmarks" menu and the context menu displays.
- Right-click again and the menu re-displays. 
- Move mouse pointer and right-click again, context menu re-displays in new location relative to pointer. 

Now to make this totally consistent with the way right-click context menus work in Windows and OS/X, is a right-click on an item in an already displayed context menu, should activate that item (essentially, the same as a left-click on the menu item). But that should probably be logged as a separate bug as to not derail this one.
Attached patch also adjusts the ids (obsolete) — Splinter Review
Attachment #373895 - Attachment is obsolete: true
Attachment #375621 - Flags: superreview?(roc)
Attachment #375621 - Flags: review?(roc)
+   * aCount is the number of popups in a chain to close. If this is 0,
+   * all popups are closed.

It would make a little more sense for 0 to mean nothing is closed and use PR_UINT32_MAX to close all popups.

+      while (--aCount && last->GetParent())
+        last = last->GetParent();
+      if (last)
+        lastPopup = last->Content();

+            if (i < sameTypeCount)
+              rollup = PR_FALSE;
+            else
+              popupsToRollup = sameTypeCount;

{} around these statements
Attached patch address commentsSplinter Review
Attachment #375621 - Attachment is obsolete: true
Attachment #376067 - Flags: superreview?(roc)
Attachment #376067 - Flags: review?(roc)
Attachment #375621 - Flags: superreview?(roc)
Attachment #375621 - Flags: review?(roc)
Attachment #376067 - Flags: superreview?(roc)
Attachment #376067 - Flags: superreview+
Attachment #376067 - Flags: review?(roc)
Attachment #376067 - Flags: review+
Flags: wanted1.9.2?
Anything we can do to have this checked into trunk?!?

~B
Neil is away (vacation?) until the 25th of May, he'll probably check it in, soon after that date.
But we could set checkin-needed. Probably someone will get to it earlier.
Keywords: checkin-needed
Checked this in as well as added an ifdef in nsWindow.cpp to unbreak wince.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
I'll try to file a new bug on the following:

1) Right click on one folder or bookmark in the bookmarks menu and don't click or do anything else!
2) Move your mouse to a second folder or bookmark (that doesn't reside in the previous folder) and left click twice to select that new folder or bookmark
3) Observe that the first folder or bookmark menu isn't dismissed; if you keep doing this you'll have a bunch of bookmark menus open!
4) Subsequent bookmarks or folders that you right click on should be highlighted.  As it is now, you can't be sure what you're right clicking on.
(In reply to comment #26)
> Checked this in as well as added an ifdef in nsWindow.cpp to unbreak wince.

Neil, please add the changeset to the bug when closing it. This will help QA a lot without having the needs to search mercurial first. Thanks.

http://hg.mozilla.org/mozilla-central/rev/74959aad851c

Verified fixed on trunk with builds on Windows and Linux like Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090614 Minefield/3.6a1pre ID:20090614050328
Status: RESOLVED → VERIFIED
Flags: wanted1.9.2? → in-testsuite?
Keywords: uiwanted
Hardware: x86 → All
Whiteboard: [reproducible on PowerPC?]
Target Milestone: --- → mozilla1.9.2a1
Depends on: 498230
Depends on: 499242
Duplicate of this bug: 538152
You need to log in before you can comment on or make changes to this bug.