Error console output in month/multiweek view when selecting events in the unifinder

VERIFIED FIXED in 0.9

Status

VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: andreas.treumann, Assigned: Fallen)

Tracking

unspecified

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
STEPS TO REPRODUCE:
===================

- switch to month/multiweek view
- open the unifinder and select any event

RESULT:
=======

- Error console:

Error: this.viewElem.centerSelectedItems is not a function
Source File: chrome://calendar/content/calendar-decorated-base.xml
Line: 211

EXPECTED RESULT:
================

- no output in the error console

REPRODUCIBLE:
=============

- always

Possible root cause is bug 439245
Flags: wanted-calendar0.9?

Comment 1

10 years ago
I could not reproduce this bug. We'll keep an eye on it...
Can be reproduced using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16pre) Gecko/2008061720 Calendar/0.9pre.
(Assignee)

Comment 3

10 years ago
Created attachment 325515 [details] [diff] [review]
Fix v1

XBL peculiarities...
Attachment #325515 - Flags: review?(Berend.Cornelius)

Comment 4

10 years ago
Comment on attachment 325515 [details] [diff] [review]
Fix v1

You live and learn. Patch looks and works well. My comment #1 was wrong because related to Bug 439609 – Error console output when mouse clicking the calendar day/weekview.
Attachment #325515 - Flags: review?(Berend.Cornelius) → review+
(Assignee)

Comment 5

10 years ago
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: wanted-calendar0.9?
Resolution: --- → FIXED
Target Milestone: --- → 0.9
(Reporter)

Comment 6

10 years ago
Checked in lightning build 2008061905 -> VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.