If a server timeout popup appears while moving a message to a folder, Thunderbird locks up and must be terminated using the Windows Task Manager

VERIFIED DUPLICATE of bug 100180

Status

--
critical
VERIFIED DUPLICATE of bug 100180
10 years ago
10 years ago

People

(Reporter: register, Unassigned)

Tracking

({hang})

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: version 2.0.0.14 (20080421)

When I was moving a message from the Inbox to another folder, I received a Server Timeout popup (valid).  The message I was dragging was dropped (it stayed in the Inbox), and I could not click OK to acknowledge the Timeout Popup.  Thunderbird was locked up and responded to no inputs or clicks anywhere on the screen.  I had to terminate the program using the Windows Task Manager.

Reproducible: Always

Steps to Reproduce:
1. Disconnect a mail server or do something to cause a server timeout (disconnecting the network causes a failure to rapidly)
2. Click Get Mail
3. Immediately grab a message from the inbox using the mouse and drag it into the left folder pane but don't drop it.
4. Hold the message until the Server Timeout popup appears.

Actual Results:  
Application will no longer respond to any input

Expected Results:  
The user would expect the message move would be allowed to complete before the popup appears.  Even if the move message is ignored (safe solution) in order to display the popup, the application should not stop responding.

Since the applications hangs, I put a Critical Severity on it by definition.  Since it only happens when a mail server is not responding, it probably is not a Critical Severity.
POP or IMAP?
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> POP or IMAP?
> 
I'm sorry, it was a POP server.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 100180
V.Duplicate
Status: RESOLVED → VERIFIED
Keywords: hang
Version: unspecified → 2.0
You need to log in before you can comment on or make changes to this bug.