Can´t see any menu content

VERIFIED INVALID

Status

()

Firefox
Menus
--
major
VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: Victor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; es-AR; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; es-AR; rv:1.9) Gecko/2008052906 Firefox/3.0

When click on any manu firefoxjust  displays something like a big panel form side to side of de screen and doesn't show any letters so i'm unable to see which menu i'm accesing to.

Reproducible: Always

Steps to Reproduce:
1.Click on any menu (file, edit, ...)
2.
3.
Actual Results:  
Instead of the menu content, firefox shows a flat item which doesn't show nothing and this item is normal size in top/down shape and screen-wide size.

Expected Results:  
Firefox must show the menu in the normal form and shape

Default theme, fresh installation, windows vista with windows blinds as a theme manager and using windowblinds and Leo(Vista) as a OS theme.

Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-GL -wd4624 -wd4952 -TC -nologo -W3 -Gy -Fd$(PDBFILE)
cl 	14.00.50727.762 	-GR- -GL -wd4624 -wd4952 -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-update-packaging --enable-official-branding --enable-jemalloc --with-crashreporter-enable-percent=25
(Reporter)

Comment 1

10 years ago
Created attachment 325767 [details]
Desktop snapshot that shows what happen when click on any menu

Comment 2

10 years ago
1) Does this problem go away if you disable the Windows Blinds theme?  There are some known issues with how menus are handled in Vista with respect to third-party system themes.

2) Could you please post a link to the WB theme that you are using?
(Reporter)

Comment 3

10 years ago
1) No.

2) I'm looking for it but i can't find it, just know is made by "stardock design" and it seems to be removed from www.wincustomize.com" 

Comment 4

10 years ago
I can't reproduce your problem.  I downloaded the latest version of Windows Blinds (which apparently includes the Leo (Vista) theme).  And everything looks fine.

The only thing that I could think of that would cause a huge menu like that is if attempts to get the menu metrics are failing, which would cause us to use bogus values.  But I don't see that problem with the latest WB version and with the Leo theme that came installed with it...

You don't have any extensions installed, do you?
(Reporter)

Comment 5

10 years ago
No, i haven't. It also occurs when click the No-Script button "Options" or when i right click on any web page. I have the same configuration this morning running well with firefox 2
Do you get the same problem if you run firefox in the Firefox safemode ?
- http://kb.mozillazine.org/Safe_mode

(Reporter)

Comment 7

10 years ago
yes my friend, same problem. look the attachment
(Reporter)

Comment 8

10 years ago
Created attachment 325793 [details]
Desktop snapshot that shows what happen in safe mode (same problem)

Comment 9

10 years ago
Victor: latest version of WB?
(Reporter)

Comment 10

10 years ago
Actually 6.01 (build 57 x86 Vista Edition)

Comment 11

10 years ago
I'm using 6.1, build *97* x86 Vista Edition.  Could you try that?  Aside from WB, I really don't see many other possibilities for the cause of this...
(Reporter)

Comment 12

10 years ago
That's did the trick!! Thanks alot for your support Kai & Matti.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Verified invalid
Status: RESOLVED → VERIFIED

Comment 14

10 years ago
I'm going to mark this as blocking bug 436779 so that this remains on my radar.  Right now, there is no error checking for the retrieval of menu metrics in nsNativeThemeWin.cpp, so although this was directly a problem with WB, I think things could've been handled better on our end, too.
Blocks: 436779
(Reporter)

Comment 15

10 years ago
All right. Again thanks for your support.

Kind regards

Updated

10 years ago
Duplicate of this bug: 423398

Updated

10 years ago
Duplicate of this bug: 451972
You need to log in before you can comment on or make changes to this bug.