Crash on close tab with gmail.

VERIFIED INCOMPLETE

Status

()

Firefox
General
--
critical
VERIFIED INCOMPLETE
10 years ago
7 years ago

People

(Reporter: Kevin Norris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0

This bug has also been reported on Windows XP and Mac OS X, so I think they should be consolidated into one cross-platform bug.
Bug 428478 (windows xp)
Bug 414965 (mac os x)
This prevalence makes me think it's cross platform

Reproducible: Sometimes

Steps to Reproduce:
0.Have more than 1 tab open and a Gmail account
1.Log into Gmail
2.Wait for the inbox to load
3.Close the tab
Actual Results:  
Sometimes it crashes

Expected Results:  
It never crashes

Only seems to happen on the new Gmail interface (currently Gmail's default AFAICT)

May be observed as general instability (increased incidence of crashing) when using Gmail and doing things related to tabs (switching, closing, opening ...)

Bug 241722 in launchpad
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/241722

Severity based on linked bugs.  

Talkback doesn't open.
(Reporter)

Comment 1

10 years ago
Note, sorry about the spam: Don't click the Bug 241722 link in the "Bug 241722 in launchpad," use the URL.  Bug 241722 in this bugzilla is unrelated.  Also CC'ing myself
If you think that this bug is already reported then don't file a new bug, add a comment there !

We need a human readable stack trace, either from Breakpad or from a debugger.

Comment 3

10 years ago
do you have firebug installed. this hapenned to me with firebug.
without firebug it runs fine
(Reporter)

Comment 4

10 years ago
No, no firebug.

Updated

10 years ago
Duplicate of this bug: 440970

Comment 6

10 years ago
Same problem with same user-agent on Linux x86_64.
I think status should be set to NEW now...

For some days, gmail added another crash at login (only when checkbox "remember me" is checked). 

Comment 7

9 years ago
This may be related to Bug 458877.
(Reporter)

Comment 8

9 years ago
(In reply to comment #2)

>If you think that this bug is already reported then don't file a new bug, add a
>comment there !
No, because "there" in this case is just downstream packaging (Ubuntu), not Mozilla developers; i.e. they can't do anything except maybe make another Iceweasel.

>We need a human readable stack trace, either from Breakpad or from a debugger.
Breakpad doesn't launch.  I think maybe Google fixed this while we were discussing it (I use "we" in a very loose sense since I didn't really take part in this to any great extent), which means it may be time to close this bug.  What to put as the resolution is entirely beyond me...
We need either a Stacktrace with debug symbols or a breakpad ID.
Breakpad is only included in official builds because the breakpad Server needs the symbols from the build process. The symbols are uploaded to the crash server during the Mozilla.org build process and that's the reason why breakpad can not work with third#party builds like a build from Ubuntu.

It's a bad situation for Users of third-party Firefox builds but there is nothing we could do about this.
I will mark this bug incomplete (not enough information=)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.